HP 9100, firmware upgraded to 9300, write errors

vbimport

#1

A few years ago I bought a HP Diskwriter +9100. The drive does CDR at 8X, CDRW at 4X, and reads CDs at 32X.

The little drive did pretty well over the years and the only problem I ever had was copying CD to CD from my CD ROM to my CD writer. My CD ROM drive is a 50X Asus drive. If I lowered burning speed to 4X it worked fine 99% of the time. I blame crappy source disks (my kids are hard on their game CDs, so I try to make back ups while they are new. Some could only be READ at 4X).

Very shortly I’m going to be upgrading to a DVD burner (haven’t decided which one for sure yet) and while doing research I thought it might be fun to research my old drive for reviews, etc…

I found that several people with the 9100 had upgraded their firmware to the 9300 to enable 10X burning and several others were looking for 9500 firmware for 12x burning.

I downloaded the firmware updates from HP for both the 9100 and 9300 (I couldn’t find the 9500 firmware). The automatic program only works with the original software installed (as if I can remember where I put a disc that many years ago), so I used winrar to extract the files from the install packages and used a freeware program (zipscan) to extract the actual bin files (9100_10c.ban and 930010c.bin) from the cab files.

I then used UPDCRX21 to update the firmware from a 9100 to a 9300.

Nero reported the drive as a HP Diskwriter + 9300. It showed 10x CDR burning speed.

As a test I tried to burn a 139MB .wmv file from my HD to a CDR using Nero Burning ROM. Everything looked good until the last minute when I got a “write error”. I tried a new brand of media. Same thing.

Four coasters later I changed the burn speed to 8x. Worked fine.

I looked over the logs generated by Nero and I couldn’t make heads or tales of the information. As far as I could tell it was letting me know that 10X was a no-go.

Before I flash back to the 9100 firmware, is there anything else I should try? After reading other people’s experiences I thought a firmware update would be a sure thing, I was kind of surprised that it didn’t work…

Thanks in advance!


#2

I did further research and it seems others had problems with Nero when flashing their 9100s to higher speeds. I’ll try some other programs.

In the mean time I happened to notice that one of my co-workers has a HP 9500 on his desktop. If I could just find a way to pull the firmware to a bin file…


#3

I couldn’t get any programs to burn at 10X, so back to the 9100 firmware I went.

All is fine now.

If all goes as planned I should be getting a new DVD burner soon, so this one will either be eBayed or moved to my file server.