HP 840i wont R/W at normal speed

okey i just upgraded to that drive HP 840i and i cant burn dvd-r disks at 16X or even 8X speed anymore
maximum speed now is 4X using nero
i tryed the clean install method, changing IDE cable, and making sure DMA is enabeld
i searched the forum and i knew that nvidia nforce2 have IDE controller problems so i uninstall it, runing now on xp native driver

is there a firmware update i should apply ? becouse i searched everywhere and found nothing even on HP site (my drive have S632 version)

my old MSI DR8-A was burning normally at 8X with maxell 16X blanks

my pc is amd 2.2ghz 1gig ram
36gig raptor WD (sata)
80gig caviar WD IDE
board MSI K7N2 ultra
and xp media center

im running out of ideas and thinking am i missing something or did i got faulity drive

Sounds like the mediacode isn’t supported in the drive’s firmware.

Can you run CD-DVDSpeed, and post the MID info of those discs (under the “Disc Info” tab)?

Unfortunately, I just Googled and couldn’t find any firmware, so hopefully someone else can come up with something.

:slight_smile:

Nero CD-DVD Speed: Disc Info
Basic Information
Disc type: : DVD-R
Book Type : DVD-R
Manufacturer: : Ritek
MID : RITEKF1
Write speeds: : 4 X
Blank Capacity : 4.38 GB
: 4488 MB
: 4706076672 bytes
Extended Information
Layers : 1
Usage : General
Copyright protection : n/a
Recorder information : recorded with HP DVD Writer 840x
Disc Status : Empty
Raw Data
Pre-recorded Information in Lead-in (0Eh)
0000 - 01 40 C1 FD 9E D8 52 00 02 87 0D 13 87 88 90 00 - .@…R…
0010 - 03 52 49 54 45 4B 46 00 04 31 00 00 00 00 00 00 - .RITEKF…1…
0020 - 05 88 80 00 00 00 02 00 9B 50 4A 00 5C 79 05 00 - …PJ.\y…
0030 - C6 50 4A 00 00 00 00 00 47 C2 3D 77 4E 00 00 00 - .PJ…G.=wN…
0040 - 00 00 00 00 00 00 00 00 74 79 05 00 A9 ED D4 77 - …ty…w
0050 - E0 F3 9E 00 AB 2C 00 00 A0 79 05 00 00 00 15 00 - …,…y…
0060 - 32 07 91 7C 0B 00 00 00 98 08 15 00 00 00 15 00 - 2…|…

what d H@## !!! i just noticed that write speed is 4X ??? the disk itself maxell 16x branded ???
is this the couse of my problem ??

The problem would seem that those discs (RITEK F1) aren’t supported in your drive’s firmware.

Hopefully someone can help with finding some later FW, as I’ve come up blank in my searches…

ok last update
theres member here ( cant remmber the name ) found a way to cross flash this drive using LG H20L firmware wich the 1 i have
now i have fromware 1.1 but the damn thing still refusing to go higher than 4X :a

second step is to check the media code inside the firmware file, and to do that i used media code speed edit
changed the speed and reflashed the drive, bang !!! i can see 8X and 12X now avalible in nero , try to burn at these speeds … no luck burn errors :a
back to square 1 :sad:

alright after searching forums and read everything related to this drive
thats it i had enough . im returning this drive, very problematic readings and firmware missing many media codes

ordered Benq DW1655 :bigsmile: