HP 640c (BenQ 1625) media compatibility

vbimport

#21

Yes, the disc that came with the drive labeled without a problem. That is why I was so surprised when the 25-pack of H.P. branded CD-R 52x disc would not label no matter what I tried. Returned that drive to supplier and they gave me a HP replacement to try. Waiting for new media to arrive. Should arrive tomorrow so might know something by tomorrow afternoon if different media fixed my problem. Also noticed that HP has removed one firmware update that was on their web site. They also now have a newer version which I have installed in this replacement drive.

Take care!
Better Tomorrows


#22

Mrwoodo: I am now happy to report that my problem with writing to lightscribe CD-R 52X media labled HP is now resolved. The Verbatim CD-R media that I had ordered arrived today. Tried to write a label and all went well. A label was created without any problems what so ever. The only thing that is different in my system would be the media so I am guessing that either the media or drive that I returned to supplier were defective. :wink: :clap: :iagree: :bow:

Tascosa


#23

Great stuff :cool:

Yeah for my problem I’ll just stick to +R’s and check once in a while to see what firmware’s HP comes up with !

Cheers


#24

You might ought to check to be sure the DMA is enabled.
If you have the Nero software, check it through there, it will
tell you if it is or not.
HP told me the latest Firmware for this DVD writer is: JS04, but I have
a hunch that was a typo from them. I think ES04 is the latest from
everything I have seen so far. But they also said to be sure the DMA was enabled.
Hope it helps.


#25

I have the same drive. I called HP and got a new drive sent out to me. It still does not recognize blank media. However, it does burn without a hitch using Sonic Record Now that came along with my Pavillion 850y. Mine will burn using any dvd or cd-r media. Works best with Memorex, but I was hurt to find out that it only burned dvd+r media at 16x and dvd-r at only 8x.


#26

Hi,
I changed my 640c but I still can not do a light scribe. I am using Verbatim +R.
It just keeps saying no lightscribe media detected. I also tryed all the lightscribe updates. Can someone please help me?
Thanks
Mark


#27

Are you putting in the Lightscribe disc with the LS surface pointing down ? (which is the correct way to burn a LS disc)


#28

try the drive in another computer, pref. with a completely different motherboard chipset.
that’ll rule out whether it’s software or hardware…
then if the hardware is OK, try reinstalling Windows.


#29

Can anyone pm the link to WinDWFlash? I would really appreciate it. Thanks, Ryan


#30

how come my 1625 does not recognise any light scribe disc?


#31

Hi guys.
I am having trouble with my HP Dvd Write 640c (thats my Device Manager says it is), as per HP’s support website I’ve upgraded firmware. The only problem i’m having is discs aren’t being recognised, whether it be a dvd, cd, in fact ANY disc. The computer recognises the drive, it ejects when i select eject from right clicking on the drive etc…
I have tried using Benq firmware as per previous posts, but it won’t even let me do that. I’m thinking it may be the actual drive that needs to be replaced… anyone help at all though? really dont want to go through the hassle of getting a new one etc…


#32

Thank you!


#33

This is the drive that Ihave TSST corpCD/DVDW SH-S162LLC02. Thisdrive was working good in a P4T533 Asus mobo, however I switched it to a Dell Optiplex and is not recognizing or reading DVD-RW’s. Any suggestions please!

Thank you


#34

Sorry to say Chuchito, but you’r in wrong forum section. :sad:

You better ask moderators to move your posts to Samsung forum.

Thanks. :flower: