How to use ImgBurn and CD Speed w/o SPTI?

Hi!
I’d like to use ImgBurn, Nero CD Speed and possibly some other cd applications on my company notebook. However unfortunately i don’t have admin rights, so i can’t use SPTI and i can’t install ASPI drivers.

I’ve downloaded wnaspi32.dll from the Nero website and tried to put it into the same directory with ImgBurn/CDSpeed, but the programs still keep saying there’s no drive detected. Is there a way to outcome this situation ?

Thanks in advance :slight_smile:

Would it be possible for you to get someone with admin rights to change some permissions on your company notebook?

AFAIK the Nero BurnRights tool will allow you to enable burning for non-admin users, for Nero and other burning tools. I must admit I have only tried it with Nero, however.

There’s also a way to change such permissions using group policies, but I don’t have the information handy.

But i still cant install BurnRights without admin access. The problem is, that i work in a very large company, so if i want anything from the IT guys, i need to fill a form. They look at my job description and decide that i dont need SPTi to get my work done. They even refused to give me internet access :a

So there’s no way to enable ASPI support without istalling anything into the system ? I even tried a thing called FrogAspi, but still no luck :sad:

None of the ASPI DLLs will work except the Adaptec one (and that’s not recommended for Windows XP etc) because they’re just wrappers for SPTI.

If all else fails you could alway just reset the local machine’s Admin password via any number of tools created for such a purpose.

It takes about 2 mins to do.

There might be a way to save the existing admin password hash somewhere and then put it back again when you’re done, I don’t know - otherwise any login attempts using the local admin account with the real password will fail.

Once you have access via the local admin account, login, install burnrights or whatever and be on your merry way :slight_smile:

I have WNASPI32.DLL working with Imgburn without having Nero currently installed. However, the only way I could do it was to install Nero. Then, export all of the registry entries referring to Nero/WNASPI32.DLL. Then, uninstall Nero leaving a copy of WNASPI32.DLL in the Program Files/Ahead/Nero/ folder afterwards. And, then restore the registry entries by clicking the exported .reg files. Afterwards, Imgburn still works with WNASPI32.DLL. At least in my case it does.

I doubt thats the best solution. Copying the necessary DLL into the windows sys32 folder would have been more than enough!!

Why not? The method you describe (or putting the DLL in the Imgburn program folder) did not work for me without having Nero installed. I tried that first, of course. By restoring the registry entries it works without Nero, it’s simple and no danger as long as you’re careful.

[QUOTE=chef;2676389]I doubt thats the best solution. Copying the necessary DLL into the windows sys32 folder would have been more than enough!![/QUOTE]