How to upgrade your Asus BW-12B1LT to LiteOn iHBS212-2

vbimport

#1

Hello all.

I’ve found this forum very informative, so first of all, I would like to thank everyone for your generous help. And ask for a little more… :wink:

There is a thread about How to upgrade your Asus BW-12B1ST to LiteOn iHBS112-2 which I have read. I made a mistake and followed these instructions for an iHBS112 but I have a Lightscribe unit and I should have used firmware for an iHBS212. :rolleyes:

So my BW-12B1LT now has the PL06 installed and burning software won’t recognize recordable media. Nero Info Tool sees CD-R and DVD-Rs, reads the drive capabilities correctly, but doesn’t see DVD-RWs. Windows properties shows the unit can record. I tried DVD Decrypter, Ashampoo Burning Studio and Adobe Encore: no disc in drive. Can play, not record.

I tried flashing 5L03, 5L09 and HL05 firmwares with the Flash_Utility and AL18.EXE but after a while the flasher says they’re not for an iHBS112, and won’t let me.

Can this be fixed or did I just mess it up for good?


#2

The unlocked flasher method only works with unscrambled firmware. Here is the firmware you need.


#3

Thanks, anywhere!

I was able to use that bin file, and the unit is identefied as an iHBS212.

But now… it’s back to a blinking LED on the drive. Yesterday I was able to fix that with the EEPROM_Utility, using “Convert Drive”. But now that’s not working: at the end of the progress bar a pop-up says “Sorry but this drive cannot be converted at this time”. Same thing after shutting down or rebooting.

What else should I do?


#4

[QUOTE=102db;2700770]Thanks, anywhere!

I was able to use that bin file, and the unit is identefied as an iHBS212.

But now… it’s back to a blinking LED on the drive. Yesterday I was able to fix that with the EEPROM_Utility, using “Convert Drive”. But now that’s not working: at the end of the progress bar a pop-up says “Sorry but this drive cannot be converted at this time”. Same thing after shutting down or rebooting.

What else should I do?[/QUOTE]

Please send me the eeprom back up.


#5

Problem solved!

Thank you.