How to switch to PIO mode?

Hi guys.

I have a Optiarc AD-5170a drive and I am getting many errors when I verify ISO burns. I tried different files with Nero, Ashampoo and different CDRW’s from LASER and BENQ. The strange thing is, those disks support x12 speed, but both Ashampoo and Nero only give me the option of x10 speed, nothing else.
So I thought the problem is with the firmware, and I wanted to flash the newest firmware 112bt_rpc1 with Binflash. Yeah I read all the warning about I should switch my drive to PIO mode, but I could not find out HOW to switch. I googled and read about changing in Device Manager, went there but could not find any option about PIO or UDMA4. I got into BIOS SETUP of my ASUS M2N-MX motherboard. There I found only the options PIO Auto, 0, 1, 2, 3, 4 and UDMA Auto, 0, 1, 2, 3, 4. No enabling or disabling PIO. So I left it the way it was . PIO in Auto mode , and UDMA in Auto mode.
So I flashed it anyway, and I got the checksum error.

What to do now? I wanna flash again, but how can I switch my drive to PIO?

Welcome to the forum
Probably the easiest way to get the IDE contoller into PIO mode is to boot the PC in “safe mode” (press F8 at boot and select safe mode without network support). This works in most cases.

WOW…thanks a lot, Dee-27. I just did exactly as you said. And I got a successful flash!
Now I’m trying to burn and see if there is a difference.

                      !!!   Thanks a lot for your quick response   !!!

Maybe you didn’t look in the right place in Device Manager. For WinXP or Win2k under IDE/ATAPI Controllers right click the controller the drive is on, select Properties, select Advanced Settings and finally select PIO Only in Transfer Mode settings. Change in earlier Windows will be a little different.

You are right bevills1. Now I found it too. I was looking in Device Manager in DVD/CD-rom Drives before…

Anyway I just burned again with Ashampoo, and again verification failed. It keeps telling me there is compatibility problem between my Writer and the disk (Benq CR-RW x12). And why would Ashampoo and Nero only let me burn at x10 when the disk is supposed to support x12?

Could be the speed the disc is supported at in the drive’s firmware. I have the same thing with a Traxdata 12x CD-RW disc, I’m only offered 10x at the highest with two of my drives.

bevills1 ,
I did what you said for changing udma and pio mode , but I Dont have any “advanced” settings tab or button?
I have win XP pro.

Do you have the Intel Application Accelerator software installed? You won’t get an Advanced settings tab with it. I believe some other software will have the same effect, but offhand can’t remember which.

I’d just start in Safe Mode as Dee mentioned earlier. :wink: