How to stop XP Media Center from autoloading

Everytime I put a DVD in my computer, XP Media Center always autoloads and it drives me crazy because I hardly ever use Media Center for anything DVD related. Any ideas how to stop this from happening? I already tried My Computer -> DVD player -> right click -> select autoplay -> take no action. But that doesn’t work.

microsoft powertoys -> Tweakui -> Disable autoplay :wink:

There’s also a reg hack discussed elsewhere on the forum.
The search button is your friend :wink:

Thanks. Before I posted, I had already searched the internet and this forum and wasn’t having much success. How about a keyword suggestion or a link?

http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx

http://www.dougknox.com/xp/scripts_desc/xp_addtweak.htm

Second link contains a utility which allows you to add TweakUI to the WinXP control panel.

Doug knox also has another method.

For XP home, there is a script:
http://www.dougknox.com/xp/scripts_desc/xp_cd_autorun.htm

For XP pro, there are instructions for using group edit (gpedit.msc)
http://www.dougknox.com/xp/tips/cd_autoplay_pro.htm

There is a bonus there for the XP pro version. You can disable autorun for everything including removable hard drives. (e.g. USB connected external drives).

I don’t know about you, but when I used to plug in an external drive with many partitions, I used to get that autorun stuff running multiple times. Talk about annoying! The Doug Knox group policy change put a stop to that.

Thanks, guys! I’m good shape now.

However, one question still remains…why does XP have the Autoplay selection/assignment feature if it doesn’t work?

It does exactly what it was designed to do.

Just like all programming …
-> The program does exactly what you told it to do.
-> What you want it to do is a completely different story.

If I go into the AutoPlay menu and for the DVD option select “Take no Action”, but it still autoloads DVDs in Media Center every single time (prior to the global TweakUI tweak), how can that be defined as functioning correctly? Did they really design it that way?

Also, my problem has mainly been addressed, but you never did provide any keyword suggestions for the search engine. Perhaps you could provide some tips.

Arrgh … now you’r getting technical. The autoplay feature works fine … the option to turn it off, doesn’t :wink:

Keywords: disable Autoplay
Google returns several thousand hits.
Any on the first page seem to be directly related … with solution.

Cdfreaks returns: Many hits … only this thread seems fully technically relevant.

Da_Taxman … there’s some work to do on the search feature!
Lol :slight_smile: