How to speed up torrent downloads

vbimport

#1

Anyone know how to speed them up? :confused:

I have a 2 Megabyte connection but my torrent downloads never go above 20 Kilobytes per second.

By my calculations, I should be downloading at around 190-200 Kilobytes per second. :doh:

I’m using Azureus as my torrent client by the way.

I already realise that the download speed mainly comes down to the number of seeds but I only attempt to open up torrents that have a high number of seeds (20+).

And I also have my port forwarding working ok. My Netgear router has ports 6881-6889 open.

But the download speed is still relatively slow.

Any help would be much appreciated. :clap:


#2

Download also depends on the connections of the people you are downloading from…


#3

You can’t tell me that there are 20+ seeders who have a 56k modem connection.

Why download torrents if you don’t have a fast connection?

I dread to think how long it would take to download on a connection slower than 512k. :frowning:


#4

couple of things…20+seeds on public trackers still may be painfully slow.
These are the people keeping crazy amounts of torrents seeded bassically just to make the selves feel good.
And your ports…might or might not matter but you only need 1 and most forums recommend upping your range to 45000+ some isp`s are throttling default ports of BT clients.


#5

So do you think I should change my bittorrent port? Is there any particular port number that I should use?


#6

Azaureus has a green smiley, does it? that’s the marker for effective port forwarding and firewall passge.

You could be sufferring from port throttling, though traffic recognition could be used instead, making port manipulation ineffective.

The other thing, how’s your upstream?

If you allow outgoing traffic to saturate your upstream (normally a much lower speed than down - for a 2Mbit, 512k or even 256k), then the delay it causes to responses decimates your usable download speed.

Limit the maximum upload to 80% of your available upstream, less if you use anything else with signignificant upstream requirements at the same time.


#7

I changed my Bittorrent listening port to 45001 and applied the new setting in my Router’s control panel.

Yeah, Azureus has a green smiley in the My Torrents window. I’m sure my upstream is 512k.

The Max Upload speed is currently set to Unlimited. Is that going to lead to further problems?


#8

Also, enable encryption in the settings as some isp’s are using traffic shaping. I use Tiscali and my speeds went from about 10kBps to 55kBps (depending on torrent) on a half meg connection. The azureus wiki has a guide on how to do this. Port 443 works best for me


#9

I tried going through the guide (below) but I can’t seem to find an option in Azureus where I can turn on Encryption.

http://azureus.aelitis.com/wiki/index.php/Encryption#When_to_turn_it_on

There is no ‘Transport Encryption’ option in my version of Azureus. Anyone got any idea what I’m doing wrong here?


#10

“To enable the encryption you have to switch to intermediate user mode and go to Tools -> Options -> Connection -> Transport Encryption and enable the Require encrypted transport checkbox.” this is taken from that page, make sure you are on intermediate mode. If you dont have an encryption option you need to update to the latest release


#11

I’ve updated to the latest version of Azureus and I’ve got the Encryption options available to activate/deactivate.

I’ve enabled the ‘Require Encrypted Transport’ option but another drop down box appears. Which encryption should I choose - Plain or RC4?

And also there are two other tick boxes beneath the encryption drop down box - ‘Allow non-encrypted outgoing connections if encrypted connection attempt fails’ and ‘Allow non-encrypted incoming connections’. Do I need to enable one of these options aswell? By the way, I’m with Tiscali aswell - a 2 Meg connection.


#12

If you are using Tiscali then you want rc4 (higher encryption). Try clicking both boxes but if you see no improvement after half hour then try unticking them (the incoming one first). Ports 80 and 443 are the best two I have found so far with Tiscali, they are both ports they cannot block. I like 443 because it is the port used for SSL so does not take much traffic


#13

I’ve done everything you said, I have noticed some differences but I’m a bit concerned about the lack of seeds Azureus connects to.

At the moment, I can only connect to a maximum of 5 seeds (from a torrent that has 3465 seeds). But the average download speed is around 40-50k per second.

If Azureus manages to connect to over 100 seeds (which is very much possible for this particular torrent), then I should be getting download speeds close to 200k per second really.

Is there another setting I need to change in order to get Azureus to connect to more seeds? It’s really weird because I could connect to more seeds using port 45001 but the download speed is about the same as it was for port 443. :confused:


#14

If you have disabled [B]non-encypted incoming connections[/B] you can only connect to peers/seeds that have encryption enabled which may account for your problems. Are you basing the number of seeds on figures from a BT listing site? Those figures can be total b*****ks on some sites. If azureus is showing lots of seeds but you cannot connect to them then there may be a problem. Also, what is the model no. of your router?


#15

dont forget that the package is probably up to 2mb broadband.


#16

Yep, unlimited upload strangles your download as you’re on adsl.


#17

Non-encrypted incoming connections has been enabled (ticked).

As for the seed statistics, in Azureus; the seeds tab is showing me ‘4 (3658)’. This means that I’m only connected to 4 out of 3658 seeds, right?

My router is a Netgear DG814. But I don’t think my router is the problem.

I never had any problems when connecting to seeds via port 45001 and the default bittorrent port (6881). I think the problem lies with either the encryption level or port 443.

Yeah but even so, the lowest speed I ever get is around 1.7 Mb per second (I check the speed regularly via the adslguide.org.uk website) and that’s during the daytime. Which means that I should have a download speed of at least 160-170 Kb per second.

It’s only 2 Megabytes during the evenings which should allow me to download at 200 Kb per second.

Ok then, so what should I change the upload setting to?


#18

Have a play around with yr settings is all I can suggest, what works for me might not be best for you. It took me a while to get my settings just right. My torrent speeds drop to around 5kBps in the evenings, make sure you have read Tiscali’s fair usage policy, as they may have put you on the heavy users pipe which means you are sharing bandwidth with other P2P users, so you have no chance of getting good speeds. They are supposed to inform you before doing that but apparently they often do it without warning :frowning:


#19

Ok then, so what should I change the upload setting to?
Use the azureus configuration wizard and set speed to xxxx/256 and it will automatically limit your upstream speed and connections. I hope you can get it running good as BT is by far the best P2P when it is running properly imo


#20

Well from what I was told by Tiscali Customer Services (back in October), the Fair Usage policy only applies when you exceed 100 Gb of activity in any one month. My usage is around 4-5 Gb per month including the p2p downloads.

This is the official link for the Tiscali Fair Usage policy:

http://www.tiscali.co.uk/products/broadband/fair-usage-policy.html?code=ZZ-NL-11EE

I haven’t received any e-mails from Tiscali (in both my Tiscali e-mail account and my alternate e-mail account) saying that I’m overusing my connection. So I think that my connection is perfectly fine.

It’s done.