How to shave off a bit?

vbimport

#1

Well, here I am again with a bunch of great quality Xvids that are all VBR. Damnit! These bastards are tough to do anything with. The problem is, I want them all to fit on one DVD, and I’m running over the limit by about 100M. (I might be able to get away with 50M, if I overburn) There are 13 files. What’s the best way to shave a bit off of a few without degrading the quality too bad? I’ve been trying several things, but always end up with lower quality video, so it seems. I wish I could just trim the start and end of a few of these, but that seems to cause audio sync problems. Man, why do people keep encoding VBR’s?! They absolutely suck to work with! :frowning: Is there some automatic program people use that does that?


#2

They use VBR for the audio to minimize the audio size, therefore maximize the video size to fit to 1 CD, 1/2 CD, etc Therefore you get a better picture. Change the audio to CBR and then everyone will complain about the crap picture quality :frowning: You cant please everybody all the time :smiley:


#3

Is it both video and audio that’s VBR, then? I don’t lose any quality if I convert the audio to CBR, and direct stream the video, but then I’m not saving any space either. It really doesn’t save much space to have VBR audio.


#4

Well, actually…I just tried it and burned it to a RW disc. It looks a bit pixely when viewed on my DVD player. Is there a way to re-encode it without that happening? Would i have to decompress the entire video, then recompress it again? If I do 2 pass encoding, does that make it VBR? How do I recompress it VBR? I mean, shaving 10M off of a 350M video shouldn’t make a noticeable difference in quality, should it?


#5

Not sure what your trying to do. Are you just trying to copy 13 avi’s to a dvdr blank as a data disk (but the sum of the 13 is 100mb to much) or are you trying to encode to dvd compliant mpeg2 streams. If the later, what program are you using? What are the specs of the avi’s (use GSPOT for that) ?


#6

I have 13 files at 350 - 360MB, and that comes to about 4600MB I need to get it down to about 4500MB so I can fit it on one DVD. That’s all. Bitrates all vary slightly, but they’re Xvids around 700 something - 800 something kb/s with VBR audio, which also varies. What else can I provide? My LiteOn DVD player plays Xvids, so there’s no problem leaving them in that format. I just want them to fit on one DVD. They’re so close, it would be a shame to have to separate them between two discs, ya know?


#7

No ideas? :confused:


#8

Then simply just cut off the trailing credits (assuming they are there). Load them into Virtualdubmod, say NO to any VBR Audio error that may pop up. Use the slider and the 2 small arrows to mark out the bit you want to chop off, then hit Delete key. Set Video to “Direct Stream Copy” and then Save As, giving a new name. Do that to each or until they fit to the one DVDR.


#9

Ah, I was trying to do that, but wasn’t quite clear on whether I should be using direct stream, or what. This should only trim it and leave the rest alone then, right? Thanks, I’ll give it a try.


#10

Perfect! That worked out exactly like I wanted it to. I think I’m getting a better grasp on vdub now. There was just a few things I wasn’t quite clear on. (I’m sure there are a few more) Thanks!


#11

Glad to hear its working for you :slight_smile:


#12

Well, one problem, though. The ones I trimmed skipped a frame or two every so often when I played them on the DVD player. Any clue what could cause that? It never got out of sync, but the video fluttered here and there. It’s always something, ain’t it?


#13

Nobody has any idea about this? There must be something that caused it?


#14

Its nothing to do with the trimming/cutting/conversion. More likely the actual DVDR Media and burn speed, have a read in the media forum.


#15

Hmmmm, but it’s only the ones that I edited. The ones I left as is are fine.


#16

I’ve never experienced such a problem using VirtualDUBMod, nor have I heard of anyone else so I feel confident that VDM is not the problem. HAve you kept the file name similar/same as the origianl file? Try burning them to a DVDRW and see if the problem is still there. Do they still skip ? If not, then its not the avi file.


#17

Hmmm, I don’t have any DVDRW’s, but I can try burning them to a CDRW, I guess. Yes, the filename is the same, actually.


#18

Yep, I tried it. Same thing.


#19

Did you use VirtualDUB or VirtualDUBMOD ? The later is what you need. Also, when you loaded the AVI into VDM, did you get an error message box appear about the Audio being VBR and asking to change headers. You MUST answer ignore here and NOT the Yes option. What did you select ?


#20

I used VDubMod, and I chose no when it asked me to rewrite the header…as you said above. Crap! Why does everything have to be so damn complicated? Why can’t it just work? :confused: