How to re-enable Auto Insert Notification in Windows XP

vbimport

#1

Recently I had a problem where when I inserted a new CD/DVD into one of my drives it would show the files in the right hand pane of Explorer but not the volume name on the left hand side of Explorer. And if it did show the volume name, usually after a reboot with the CD/DVD still in the drive, it wouldn’t remove the volume name after I ejected the CD/DVD. Even when I inserted a totally different CD/DVD the volume name from the old disc would still show in Explorer even though the files that showed in the right hand pane were from the new disc that had just been inserted. This was driving me crazy to no end and when I searched for a solution I realized that a lot of other people were having the same problem. Just about everywhere I looked people made reference to either the Windows XP Autorun setting or the Auto Insert Notification setting. Now in just about every case it seems that people didn’t know the difference between the two settings because in just about all instances the item they described how to enable or disable was the Windows XP Autorun feature even though most referred to it as Auto Insert Notification. Now in the old days of Windows 9x you could enable or disable Auto Insert Notification by simply removing or replacing the checkmark in Device Manager for the drive in question but in Windows XP its not that easy. So here is the solution I found and hopefully it helps out a few other people as well.

First of all you need to open Windows Registry Editor (regedit). To do this go to the RUN command and enter “regedit” and then press ENTER. Then browse down through the following key path.

HKEY_CURRENT_USER
Software
Microsoft
Windows
CurrentVersion
Policies
Explorer

Now look at the “NoDriveTypeAutoRun” key on the right. To enable Auto Insert Notification, right-click on that key, select Modify and change the value to 0000 95 00 00 00 and click OK. Now quit the Registry Editor and restart Windows for this to take effect.

For those of you that don’t feel comfortable messing around with their registry I have uploaded a .reg file in a ZIP that will automatically make the necessary changes, all you have to do is download the ZIP file and open it in your favorite ZIP file handler (ie. WinZip, WinRAR, WinACE) and double click on the windows_autorun.reg file inside. Then restart Windows for the changes to take effect.

Thats it, your drives should now refresh their content automatically when a CD/DVD is inserted or ejected from the drive.

Your welcome. :slight_smile:

PS - This has only been tested to work safely on Windows XP so I take no responsibility for what could happen to your system if you try this on any other version of a Microsoft operating system.


#2

…change the value to 0000 95 00 00 00 and click OK.

Seems to be too many numbers there and it doesn’t match what is in your zip file.

Thanks for this info. Do you know what value would be needed to turn it off as well?


#3

When you click modify on the registry value it shows “0000 95 00 00 00”. Presumably 0000 is the line and 95 00 00 00 is the data value but for the sake of simplicity I stated that you should change it so the value in the key reflects “0000 95 00 00 00”. As for a disable setting the value in my registry before I changed it so that it would work was was “0000 91 00 00 00”. So if you really wanted to disable Auto Insert Notification then I suppose setting it to that value would be disabled.


#4

… or you just use the Microsoft Powertoys “TweakUI” and go to “My Computer” -> “AutoPlay” -> “Drives” / “Types” and ENABLE all options / drives …
very simple, very quick, very safe… :wink:


#5

Autoplay or Autorun and Auto Insert Notification are not the same thing. Auto Insert Notification MUST be enabled for Autoplay/Autorun to work but it doesn’t matter if Autoplay/Autorun is enabled in order for Auto Insert Notification to function. Auto Insert Notification is the function of Windows that tells Autoplay/Autorun when a new CD has been inserted, Autoplay/Autorun simply runs the Autoplay or Autorun feature depending on the type of disc inserted into the drive. Auto Insert Notification is also responsible for changing the volume label in My Computer or Explorer when a new disc is inserted into or ejected from one of your optical drives.


#6

you can enable / disable both, Autoplay (-run) / Auto Insert Notification in the latest Tweak UI (2.10.0.0) - the names are wrong, but if you disable the DRIVES under “drives”, Auto Insert Notification will be DISABLED, so e.g. if you disable the drives, but enable the settings under “types”, autorun will not work and windows will not recognize any disc-change until next reboot any more…


#7

TweakUI was the first tool I tried to solve this issue and it didn’t work for me. If it works for others then that’s great because obviously its much easier and safer and I suggest that anyone having this problem try Razor1982’s method first but in the event that TweakUI won’t fix your problem, as it wouldn’t for me, then my method of fixing the issue is there as a backup. Its always great to have multiple ways to attack a problem. :wink:


#8

Thanks a lot! I couldn’t get TweakUI to do what I wanted, but your method did the trick.


#9

I used DVD Decrypter to do it. Just a tick in the box, safer that way for most users.


#10

Hmm try NitrousXP this is powerfull tool to optimize WinXP got all u need and more =p


#11

Firstly, many thanks to 88keyz and others in this thread. I have now partially solved a problem that has been nagging to be fixed for a number of months. I have 2 drives in the computer: 1 x CD ROM and a CD-RW. Prior to using registry fix posted by 88keyz, both drives had the same problem as posted by 88keyz. After trying manually a number of times, the problem still persisted. However, after (registering on this forum and downloading the offered Zip file) running the regfix the CD-RW recognizes inserted discs correctly. The CD ROM does not. Obviously, there is another problem and I have not been brave or knowledgeable enough to go into other places that control Master and Slave or anywhere else that may resolve the problem. Is there someone out there like 88keyz who can write clear, easy-to-follow instructions (or point me to another fix) on what I can do to to overcome the non-recognition by the CD ROM drive? I shudder when I read advice like: “Hopefully both drives are connected to the secondary ide controller and one is jumpered as Master, the other as Slave. (unless you have a Cable Select (CS) system.) And hopefully both ide ports are enabled in pc bios setup.” Other forum threads mention that some CD/DVD Burning programs will switch Auto Insert Notification off to prevent a burn failure. Is this a problem to be contended with? I have NERO latest version installed. Again, many thanks - Mac - (Andromeda M31)


#12

Does your optical drive (CD-ROM) still show up in My Computer with a drive letter? If not then you might have corrupted upper/lower filter drivers. For a fix to that problem try here. If that is not your problem then I’ll need more details.


#13

Hey guys, When i put in a disk such as a game it doesn’t show that i have the game in (by looking at My Computer) and it doesn’t autoplay. If i choose to explore the disk i can see the files there. I have tried using your registry zip file but it didn’t work.

Thanks :D.


#14

Hey 88keyz: Thanks for the regedit tip! This fixed a problem I’ve had for months. Note to other readers: In regedit it’s easy - once you finally get to the right place. Just change 91 to 95, then exit and reboot. Also, the HEX code is 0x00000095, Decimal is 149, and binary data code is 0000 95 00 00 00.


#15

just thought i’d clarify things abit. most of this is directly from Micro$oft’s website. also, it should be noted that M$ doesn’t call it Auto Insert Notification anymore (at least not in XP). it’s simply grouped into the same category as AutoRun now, even though there are 2 distinct registry locations.

the following is for Windows XP. scroll down for WinME and earlier:

AutoRun/AutoPlay:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom
DWORD=AutoRun
set to 0 for off, 1 for on.

Auto Insert Notification:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
DWORD=NoDriveTypeAutoRun

and

HKEY_USERS.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
DWORD=NoDriveTypeAutoRun

How you modify this subkey depends on the Autorun feature that you want to disable. For more information about Autorun registry key values, visit the following Microsoft TechNet Web page:
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/91525.mspx?mfr=true

Autorun is also known as AutoPlay. The following table shows the settings for the NoDriveTypeAutoRun registry value.

Value:Meaning:
0x1 Disables AutoPlay on drives of unknown type
0x4 Disables AutoPlay on removable drives
0x8 Disables AutoPlay on fixed drives
0x10 Disables AutoPlay on network drives
0x20 Disables AutoPlay on CD-ROM drives
0x40 Disables AutoPlay on RAM disks
0x80 Disables AutoPlay on drives of unknown type
0xb5 Disables AutoPlay on ALL drives
0xFF Disables AutoPlay on all kinds of drives

The default value for NoDriveTypeAutoRun varies for different Windows-based operating systems. These default values are listed in the following table.

Operating system: Default value:
Windows Vista 0x91
Windows Server 2003 0x95
Windows XP 0x91
Windows 2000 0x95

Autoplay is also disabled on any drive if it is disabled by the value of NoDriveAutoRun (in HKLM or HKCU) or NoDriveTypeAutoRun (in HKLM or HKCU). But if NoDriveAutoRun or NoDriveTypeAutoRun appear in HKEY_LOCAL_MACHINE, the corresponding entries in HKEY_CURRENT_USER are ignored.

Alternate Solutions:

Right-click on the drive icon for your CD drive, CD recorder, or DVD drive, and select Properties.
Choose the AutoPlay tab, and choose the desired action for each type of CD. For example, choose Music CD, then click Select an action to perform, then select Take no action.

Obtain and install TweakUI (part of the PowerToys for Windows XP package), and then start TweakUI.
Expand the My Computer branch, then the AutoPlay branch, and then select Drives.
Turn off the checkbox next to each drive letter for which you want AutoPlay disabled.

Windows ME and earlier solutions:

a quick note: although the number is the same for both ME & XP (95 or 91), XP (and other NTFS systems) has it set as a DWORD Value (0x00000095), where ME and previous Windowses should be set as a Binary Value (0000 95 00 00 00). (see below for details)

Run the Registry Editor (REGEDIT.EXE).
Open HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer.
Change the Value of NoDriveTypeAutoRun from 95 00 00 00 to BD 00 00 00.
You might have to restart Windows for this change to take effect.

Alternate ME Solutions:

Right-click on the My Computer icon (or whatever you’ve renamed it - hopefully something less cute and more meaningful than “my computer,” such as “Bart”), and select Properties.
Choose the Device Manager tab.
Open the CD-ROM branch, and select the entry for your CD-ROM drive.
Click Properties, and then choose the Settings tab.
Turn off the Auto insert notification option.
Click OK, and then OK again. You’ll have to restart Windows for this change to take effect.

Because of new features in TweakUI, this can now be truly disabled by turning off the Play audio CDs automatically and Play data CDs automatically options in the aptly-named Paranoia tab.
Also, make sure that the AutoInsertNotification option is turned back on - see Solution #1 above for more information.

Note: With this solution, Windows will still be notified when you insert a new CD, so you may not want to do this if you use CD Recorder software (the constant polling can interrupt the recording process).


#16

Thanks a lot, the zip file fixed an issue with RealPlayer, where the software didn’t recognize blank cds that I inserted. Zip file fix = awesome.


#17

Good Day! I would like to seek help here for my autoplay activation problem. I already browsed a dozen sites and did everything including the zip file that was recommended here, but still, the autoplay down. I know that when XP appeared autoplay had a slightly different approach from Autorun. What i want my drive to do is Autoplay, meaning I would only want it to show the contents types of my archive cd and allow me to select what to do with it. As a history reference, I installed a Daemon tools freeware and after it attached a search toolbar on my Firefox I decided to uninstall the sucker, it also changed the drive letter on my DVD player for F: to H: (if that is relevant). I tweaked around the registry destroying every piece of that annoying program, my XP SP2 is still running smoothly so I assume everything I did was right Then I realized when I inserted a flash disk then a CDR that it does not Autoplay, then, as said I tweaked everything that had to do with Autorun on XP but still no go, The drive still runs under Windows explorer but it’s a drag for me to right click all the time. Is it possible for that Darn program to have deleted a component on my DVD Drive? Please, kindly help me out with this problem. . .:confused:

UPDATED!!! FIXED IT!!! MY STUPIDITY OR MY HUNGER GOT THE BEST OF ME!! THE OPTION WAS “TURN OFF AUTOPLAY” AND I ENABLED IT! THINKING IN REVERSE!! (ORE NO BAKAAA!!!), BUT ONE THING I’M SURE THAT DARN PROGRAM ENABLED IT CAUSE I NEVER TWEAK THE SYSTEM FOR JUST ANYTHING… THANK YOU AND SORRY FOR THE BOTHER…^_^;


#18

Had problem with XP suddenly not showing flash drives in My Computer. Used the zip file after backing up registry (saw a few differences in my registry, so decided to take a chance–could always restore and checked out clean as a whistle :wink: and AIN seems to have been the problem. And your fix worked like a charm! Thanks for taking the time for detailed explanation of your reasoning etc. Such approach is very helpful all round and certainly was in this case. :clap:


#19

Thanks, I will try this and see if it works. When I went to input the long number you gave I found that there is only a 2-digit number, so I got confused. But I will try your upload.


#20

[QUOTE=FionaL;2655319]Thanks, I will try this and see if it works. When I went to input the long number you gave I found that there is only a 2-digit number, so I got confused. But I will try your upload.[/QUOTE]

Ok so it didn’t work. I basically have to restart my computer every time I want the disc to be read. Therefore I can’t install things that need 2 discs because I would have to restart the computer in between when prompted for disc 2…which obviously I can’t do. I have no idea what to do now. My AutoRun and AutoPlay options all seem to be working and enabled. Could it just be a hardware thing? Thing is the computer installs the first disc fine once it’s been recognised through a restart. So it IS capable of reading the disc, just not without restarting. Any help would be massively appreciated!