How to mount SecuROM 7 images with DT4(scsi) w/ IDE Devices attached

vbimport

#1

I have found the key which securom looks at in the registry to determine wether or not you have IDE devices attached.

The game I used was Flatout 2 (US) SecuROM 7.00.00.0001
I had already made a good image with Alcohol 120% V1.9.7
Using SecuRom 7 datatype and DPM

As usual with SecuROM (not sure which exact versions) It will check to see if you have any IDE cdrom devices, and if so, blacklist all scsi devices. That means you cannot mount to Daemon Tools because it emulates a SCSI device.

The only way around this is to unplug any IDE cdrom drives, or some people have suggested to deny read permissions to HKLM\SYSTEM\MountedDevices

But in my case Flatout 2 would refuse to run if it cant read that key.

So after messing around with the parameters in MountedDevices I found the one its looking for, and that is: HKLM\SYSTEM\MountedDevices(KEY)\DosDevices?:

Any Key (\DosDevices?:slight_smile: with offset 0x8=49

I had 2 keys with offset 0x8=49 which represent my 2 IDE optical drives, and changed 0x8 from 49 to 53 which just changes the 1st ascii char of IDE to SDE. I also tried other random values and they all worked except 49.

Now Flatout 2 works with no IDE hiding utilities.


#2

Any chance this would work with gta4? Right now all we have as far as mounting is to ysd a virtual IDE drive and cloak it with YASU. This is fine and dandy except for the fact that DT Pro (shareware) is the only app I know that can emulate IDE. Every other utility only offers SCSI, which for some reason doesn’t avert the Securom check (even with YASU).