How to flash new kys-4 firmware on my dw-q28a drive?

vbimport

#1

i am still new to this but i have been testing a lot of different burnt discs with nero dvd speed and i am not happy with the results. i have pretty high failure rates and i average around 80 for quality scores. tired several different media and the best i ever got was a 95 once on a verbatim. Seeing my buddies 3 year old $50.00 hp dvd burner getting 100 quality score with his burns is starting to tick me off. I thought i would try updating the firmware but i could not find any “how to” guides. I was also wondering if a newbie should try doing this or not? i am pretty knowledgeable about computers but by no means am i an exert. by the way i downloaded the firmware but the adobe file that comes with it requires a password. i clicked on the firmware .app file and i got an error saying “no matched drive detected”, “this is only for sony dvd rw dw q28a drive” detected drive is blank.


#2

What firmware version is your drive currently showing please? Using the Q28A_KYS4WIN.EXE flasher is easy as 1-2-3 if your drive is recognized correctly.

A good place to start reading is the FAQ and LiteOn Tools “Read First” stickies.


#3

it is at kys-1, i did find a different file and it seems to recognize my drive, asking me if i would like to continue. this does look pretty easy, if i click yes it looks like will automatically start updated my drive, but i did not want to go further until someone here tells me i am on the right path.


#4

another question about dvd speed, on one computer when doing a disk quality check the graphs show pi errors and pi failures and no jitter, running same version of dvd speed on another computer the graph displays pi errors and jitter and not pi failures. i could not find any settings that would allow user to change display types. so i was wondering if this is becuase it is 2 different burners and the different burners are tested differently by dvd speed or why this is?


#5

Yes, you can go ahead if the drive is recognized correctly by the flasher - just make sure there’s NO disc inside before you do. It will only take a minute or so to complete and ask you to reboot your PC at the end. KYS1 is the oldest firmware for this drive, which can explain your bad results. KYS4 will include more and better support for various media. But if you read this forum, you’ll know which ones are better. Don’t expect 100 percent quality scores however, 95 is more than sufficient.

On your second question, not all burners are equal and suitable for quality scanning. BenQ shows jitter in cdspeed, LiteOn/Sony doesn’t. Both will show PIE and PIF however, no need to change any settings.


#6

@kenny44
you can also use the liteon 1693s KS0B firmware. download here the file “KS0B - patched - crossflashing”: http://codeguys.rpc1.org/firmwares.html#SOHW-1693S
unpack and run the flasher.


#7

P.S. Kenny, your buddies HP probably doesn’t support PIF reporting at all, therefor comes up with none and a 100 score in cdspeed. QS is based on max PIF values only, so it’s just a rough indication of the disc’s quality anyway. You’re more likely to win the lottery than get a 100 dvd-score in cdspeed. Just so you don’t loose confidence in your burner for the wrong reasons :wink: . Your drive’s probably a much better scanner than his.


#8

CAUTION !

I saw some scans you posted in another thread recently and they show your firmware version as KFS1, not KYS1 as posted above. This is from a different series (probably specific to your Sony Vaio machine) and explains why the KYS4 flasher refused to recognize your drive. Have you searched the Sony Vaio site for updates in the form of KFSx?

If there’s nothing recent there, you can consider “crossflashing” to a different firmware series to get better media support, but this is for the more experienced and will void your drive’s warranty. If you choose to do so, it’s recommended to back up your current firmware and eeprom chip with tools like LtnFW and EEPROM Utility first. Read up on these and follow the included instructions carefully.

For crossflashing you should know that there are three identical drive models (that share the same hardware, except for their label and front bezels) to yours. These are:
Sony Q28A (f/w KYS4)
Sony 800A (f/w KY06)
LiteOn 1693S (f/w KS0B)
Please use ONLY these.

You can find respective firmwares on the codeguys site (see link above in chok0’s post). These are “flashfixed” to allow changing from one model to another and back. The reason he suggested 1693S firmware is because this is considered the best by many users of this drive. If you’re going to crossflash anyway, you might as well use that one. The “patched” version includes further enhancements by C0deKing :bow: over the “stock” LiteOn release.

Sorry for the crash-course, but this will give you a better understanding of what’s happening. I hope it works out OK.


#9

o.k. now i have screwed myself pretty good. i flashed the ksob firmware to my drive and somehow during the process i have disabled DMA(according to 1 click dvd copy) in my 1 click log it shows dma as not enabled. when i checked ide controls in hardware manager it shows dma is enabled. when checking drive info with kprobe it shows my burst rate at 13/second and i know before it was around 40. this makes me think that the dma is really disabled. also my drive makes a lot of noise now(could be related to dma issue). the only other strange thing i noticed is that 1 click dvd shows drive in the source window as 0:2:0 lite on when before when it was a sony drive it was 0:0:0 not sure what to do now


#10

also, i tired to flash it to kys4 but now the flash file will no longer see my drive as a sony, so it says that there is no matching drive installed, is there anyway to force the flash? or do i now own a lite on and there is no converting back to sony. i did not back up the existing software.


#11

OK, not to panic. You can select DMA again in Windows under System Settings -> Hardware -> Device Manager -> IDE ATA/ATAPI-controllers -> Secondary IDE-channel -> Properties -> Advanced -> Device 0. The last four steps are assuming your drive is installed as master on the secondary IDE-channel. If you have a SATA hard disk it can also be on the primary channel. Once you’ve found which IDE device refers to your burner, you can select “DMA, if available” in the corresponding box. It will be fairly obvious. Click OK to confirm and reboot the PC.

If that still doesn’t give you back DMA, you must select “Uninstall” for the Primary or Secondary IDE-channel (depending on which your burner is attached to) in Device Manager and let Windows re-install it (happens automatically) after a reboot. Check/Select DMA again in Device Manager afterwards and you should be happy.

Unfortunately there is no “stock” version by codeguys of KYS4 yet. The workaround is to use one of the older KYS1, 2 or 3 first ( link ) and then apply KYS4. Maybe do this first and then set DMA back.


#12

Also, if you have an Intel-based mainboard, you may have an application called “Intel Application Accelerator” installed on your system (should be listed under Start -> Programs if you do). This is known to interfere with firmware flashing and you should uninstall it first. You can re-install it after flashing, if you feel it speeds up your PC (the installer should be on the support CD that came with your PC or you can download a new copy from the Intel website).


#13

thanks for the help Cressida, i checked dma settings in device manager for all ide devices and they are all set to dma enabled. i was going to try and un-install 1 click dvd copy, then re-install hoping this may help. i don’t think i can flash the kys1 firmware because it is looking for a sony drive which is now a lite on.


#14

You’re welcome.

Trust me, it is possible to flash a LiteOn back to a Sony with the firmwares I linked to. After un-rar-ing (your compression utility can handle rar-files, right?) you’ll notice these are called “stock” versions by codeguys, which means they are “unscrambled” (for use with OmniPatcher) and “flashfixed” (for crossflashing - which is what you need). They are otherwise unchanged originals as released by Sony.

Your other option is to download the “FlashFix” tool (as listed in the “Comprehensive LiteOn Tools Collection” sticky in this forum) and use it on the KYS4 flasher. This way it won’t check whether the drive is a Sony any more when you flash. Haven’t used this myself though, so I’d prefer it if you run KYS1-stock for converting back to a Sony Q28A.

Re-installing 1 click dvd copy may not help with DMA, it’s probably messed up in Windows. Uninstalling the IDE-channel which has your burner on it may be the only solution (make sure you don’t uninstall the channel with your Windows drive, but since I believe your hard drive is SATA, this isn’t affected by anything you do with IDE). Here’s a useful link with some pictures.


#15

thanks again, i will give it a try when i get home from work.


#16

Cressida, well, i followed your instructions on how to disable the ide control in hardware>device manager and then reboot windows. when windows rebooted it re-installed dma and when i checked burst rate in kprobe it showed me 40mb/ps, weird noise from burner is gone and i just burnt 2 dvd’s. Another thing that this procedure did that i was trying to figure out how to do for a long time was, it re-labeled my drives in sequence. Before my dvd writer was drvie “d” and my samsung cd writer was drive “I” and now they are in order, dvd burner is “d” and cd writer is “e”. i was able to flash firmware back to kys1 and then kys4 as you explained and it worked. So you saved my ass and deserve all the credit for getting me up and running again, thanks so much.


#17

No problem, kenny44. Thanks for letting me know you’re up and running. I learned most of what I know on the subject right here myself, so it’s only fair that I shared some of it back.

Now use KYS4 and get some experience with cdspeed/kprobe scanning (use good media, burn @8X or 12X max even on 16X rated discs, use “bitsetting” on + media, defragment your hard drive periodically, don’t multitask while burning & scan @4X speed with your burner). And if you’re still not satisfied with the results, you can always try the Sony 800A or LiteOn 1693S firmwares from codeguys.rpc1.org. The 800A is the retail model (Q28A is like the OEM-version) and may get better firmware support for a longer time. Same goes for 1693S, so check for new firmware versions from time to time (although I think the current ones may be the last we’ll see for this drive). No need to get obsessed over quality scores however, a clean Transfer Rate test (F2 in cdspeed) and proper playback in your standalones are all you’re looking for really.

By the way, there’s also an option to change your Drive Letters under Computer Management -> Disc Management in Windows.

Happy burning!


#18

Hi Guys,

I have a sony dw-q28a (KFS1 firmware)
Will the firmware from http://codeguys.rpc1.org/firmwares.html#SOHW-1693S
that chok0 suggested work for me as well. The problem that I am having is bitsetting my DVD+R DL to DVD-ROM. It is greyed out using Nero CD-DVD speed.

Hope this make sense. Thanks for the help! :slight_smile:


#19

BTW, I am using Verbatim DVD+R DL when trying to bitset