How to fix: Windows Update cannot currently check for updates

vbimport

#1

A friend asked me for help with his computer that was unusually slow and had various problems. The hard disk had a few bad sectors, so I cloned it and with the new HDD installed, I checked what problems remain.

The first problem I noticed was that when I tried downloading anything in Internet Explorer, the Open, Save and Cancel buttons don’t work. I.e. it would display this “Do you want to open or save…” notification until I closed Internet Explorer:

As I thought it was likely a bad plug-in or a problem with Internet Explorer, I ran MalwareBytes, tried using Internet Explorer without add-ons and even a full Internet Explorer reset, but without any luck. So I tried uninstalling Internet Explorer 10 and rerunning Windows Update.

Well, Windows update gave the impression that it has never been used and when I clicked “Check for updates”, it said “Windows update cannot currently check for updates, because the service is not running. You may need to restart your computer.” Unsurprisingly, restarting did not work: :doh:

I checked that the service was indeed running and when I turned to Google, sure enough there were plenty of discussions about this problem suggesting various sorts of Microsoft FixIt utilities, system restore, etc. In fact, most gave just gave this vague error message “Installer encountered an error: 0xc8000247”, including the System Upate Readiness Tool that is suppose to fix this type of problem: :confused:

In the end I figured that as this installation is from a hard disk with bad sectors that something in the Windows installation must be corrupt, so I backed up the users files, did a clean Windows installation, installed the windows updates and the Samsung software for this laptop only to be greeted with the above download problem in Internet Explorer when I went to download a utility. Sure enough Windows updates gave the exact above problem again. :doh:

As the problem returned after a clean installation, I figured that it must be a driver or utility, so I did a process of elimination until I reached this innocent looking utility which I wouldn’t expect to cause a waste of an evening and such grief:

For curiosity, I reinstalled the utility and the problem returned, so was able to capture the above screenshots for this thread.

In addition to Windows update working again, the download notification buttons started working again in Internet Explorer. Finally I restored the users files. While it was a pain going through a clean Windows installation again not to mention trying to find the culprit, at least the computer feels like new again.

Hopefully this thread is helpful to anyone else with this issue to avoid a tedious OS re-installation. The affected laptop was a Samsung NP-RV510 running Windows 7 Home Premium x64.


#2

So you should have taken the red pill instead of the blue pill? :cool:


#3

@ Seán, I have the Intel software & Windows Update is working .
I will test a download to see but it worked the last time I tried one.

The difference may be I’m still using IE9 .

This is an emachines laptop . Windows7 HP x64

Edit: I just did a quick download of SpywareBlaster Install .exe & it worked correctly.
I just did one of the updates & it also worked.