How to enable Gigarec 1.4x on 716A?

vbimport

#1

I see all Gigarec options 0.6x - 1.3x yet can’t get to 1.4x (It is greyed out). I think Plextor is trying to stop us from getting to 1.4x on this drive, even though 1.4x is available on Plextor Premium drive. I think we should be allowed to experiment with 1.4x, even if compatibility is very low.

Can anyone offer some insight, or find a way to enable 1.4x on the 716A?


#2

Well, then hack the firmware to allow it :smiley:

When sending a gigarec 1.4 - command to the firmware, it sets gigarec mode to 1.3, so this is a limit of the firmware, and not an artifical limit by PlexTools:

H:\Windows2000\Microsoft Visual Studio\MyProjects\C-Projekte\plexstuff\scanning>
pxscan drivenbr=1 gigarec=1.4 debug

PxScan v1.5.3, built Feb 23 2005 14:16:49

Looking for drives...
Drive 0:0:0: PLEXTOR  DVDR   PX-712A   1.06
    command succeeded: (12) E9 00 04 00 00 00 00 00 00 00 08 00
    answer:
      04 06 00 00  00 00 00 00
  reading current gigarec setting: gigarec off
  applying gigarec setting       : gigarec 1.4x
    command succeeded: (12) E9 10 04 00 *03* 00 00 00 00 00 08 00
    answer:
      04 06 01 *02*  00 00 00 00
    command succeeded: (12) E9 00 04 00 00 00 00 00 00 00 08 00
    answer:
      04 06 01 02  00 00 00 00
  reading current gigarec setting: gigarec 1.3x

Exactly the same happens on the PX716


#3

Gigarec 1.4x is only available on the Plex Premium CD-R/RW Drive!


#4

Interesting, I suspected it was a firmware limitation. I suspect Plextor disabled 1.4 in the 716 / 712 firmware because of compatibility issues.

But they still advertise “Get up to 1GB on your 700 MB CDs.” This would imply that Gigarec 1.4x is still possible on the 716a, or is it false advertisting? 998 MB on Mode 1 would be possible with 1.4x on 700 MB media. How could the Plextor Premium have a better laser than the 716A and 712A when these drives can write DVD+/- R while Plextor Premium can’t?

I haven’t a clue how to hack the firmware to enable 1.4x. Looks like this is in the hands of the Firmware Hacking Gods. But we know it must be just a simple one-byte hack somewhere, right?

Perhaps I should write Plextor directly on the issue?


#5

I forgot to ask, but can the 712 or 716 read a Gigarec 1.4x CDR? I haven’t any here to try out.


#6

Maybe somebody should ask the dangerous brothers if they can help.


#7

The fact that it is not possible anymore to use GigaRec 1.4x in the latest Plextor Drives has nothing to do with compatibility or laser/drive quality! Unfortunately the reason is simpler… with GigaRec 1.4x and BlindWrite (Plextor Premium Mode) you can copy any protected CD you want, and the copy would completely and perfectly work in barely any cd drive… :cop: :Z :cop: Guess why Plextor has been prevented to develop and “post” new firmware updates for the Premium… :doh:
:a :a :a :a


#8

Are you sure that gigarec 1.4x is needed for that? I never cared to bushound on Blindwrite to find out what it actually is doing…


#9

Well, that is typical. It is just as I suspected, then, not a hardware or even firmware issue, but a “copyright” BS concern. The drive is meant to be used as we, the paying customers, should desire. Another “artificial” limitation due to copyright quamire… Not that I ever realized the reason 1.4x was there is to give the capability to copy any protected CD, mind you. I want to burn my own compilations with the extra capacity, not use the drive to copy already purchased CDs. Unfortunately, it seems too many others do, and this may be one reason Plextor dropped 1.4x?


#10

:disagree: :disagree:

Complete nonsense. Blindwrite uses a feature called unofficially “varirate” (not to be confused with VariRec :wink: ) that only the Premium has, and it has nothing to do with the ability to perform GigaRec 1.4x. zyzzle was initially right saying that GigaRec 1.4x was removed from 712 and 716 drives for compatibility reasons. Maybe even the other “extreme” setting 0.6x will be dropped in the future (but more “moderate settings” as 0.9x and 1.1x are being added).

BW experts, please correct me if I am wrong. :slight_smile:

ET


#11

I can only comment on the compatibility issue: My Stereo dates from 1991 and has no problems with 1.3x GigaRec discs wether they come out of a Premium, a 712 or a 716. However 1.4x discs are not recognized at all (the drive just spins the disc in an endless loop, no “no disc” error or such).

It seems 1.4x explicitly needs to be supported by the (reading) hardware used while 1.3x is still ‘transparent’ for a lot of hardware.


#12

BW experts, please correct me if I am wrong.
The question is: what is varirate actually.

One possibility is that PX712/716 cannot change the gigarec setting while recording, whereas the Plextor Premium can. But, of course, someone would have to look at the communication between BW and a Plextor Premium to find that out…


#13

I don’t know precisely how varirate operates, but I can tell you what I saw in a conversation between an italian VSO programmer and a group of people who had a px716a like me in the clonyXXL Italia forum… they were asking if it was possible to enable varirate writing to copy protected DVD with this writer assuming that it supports “VariREC” technology also for DVDs. The answer was that it is not possible, because it isn’t VariREC which is involved in varirate, but GigaREC which doesn’t exist for DVDs… And added: maybe if Plextor adds GigaREC support for DVDs it will be possible. Now if it’s GigaREC that makes varirate writing possible to use why only the Premium can do that? The only difference between Premium and px716a or px712a or any other concerning GigaREC writing is that only Premium has 1.4x… Moreover I once succeeded in making BW believe that my px716a drive was a premium, so I tried to copy a protected game cd of about 650MB… that copy obviously didn’t function, but what I noticed was that the cd was written till the very end of the disc :wink: In my opinion that was just because my drive shifted to 1.3x or less when was asked to write with 1.4x being impossible doing that…
There’s also the fact that Plextor was prevented to develop new firmwares for the Premium…
And last thing if you visit Plextor’s website you will notice Plextor’s brand new DVD writer PX760A which can write up to 18x on DVDs… that means at least very good phisical quality of the drive, but again it hasn’t GigaREC 1.4x support… Even 0.6x has been removed…
And, lastly, talking about compatibility, i tried two CDs written with the Premium at 0.6x and 1.4x in my LINN MIMIK audio cd player… it could read part of the 1.4x one almost untill 3/4 of the disc, but with the 0.6 one it even didn’t realize that a CD had been inserted… Actually I wasn’t able to find any drive able to read that cd yet (OK, i used Imation CDs, maybe that was the problem… :rolleyes: ), so in my opinion it would have been cleverer to remove 0.6x (as now has been done) instead 1.4x if it was a matter of compatibility… :smiley:

P.S. QUOTE: “but more “moderate settings” as 0.9x and 1.1x are being added”
No GigaREC moderate settings added in the new PX760A (0.9x - 1.1x)…


#14

“Varirate” sounds like (from the sound of the word) a variable GigaRec (= varying the length of the lands and pits during the burn). But that’s only a guess. :wink:


#15

Absolutely possible, and without 1.4x px7**a cannot shorten pits and lands enough… :iagree:


#16

How do you know that. Could you post the bushound log (or log made with another tool) from which you concluded that gigarec 1.4x is necessary?


#17

How can you say that? Do you already have the drive? Take a look at the image in this post. :wink:

I agree… Chaos2, can you post some proofs about what you are saying?

ET


#18

A variable rate GigaRec? It sounds like this is one distinguishing feature between the Premium and 712/716A.

I guess I got a little carried away in my last post. If 1.4x was removed for “compatibility reasons” some ingenious hacker may still be able to modify the firmware to allow it in the 716A and / or the new 760.

If Variable-rate GigaRec is possible using Blindwrite, does this mean that GigaRec can be modified to whatever rate the user desires (ex. 0.95x, 1.14x, or a value between 0.6x and 1.4x)?

Chaos2:

I’ll bet the reason your 1991 player can only access 3/4 of the GigaRec 1.4x disc is because of the infamous lack of most drives / audio players to read past 99 min 59 sec. I have three standalone DVD players which play a 1.4x disc perfectly up till 99:59 but bomb out after 100 min. On the other hand, I have two laserdisc players: a Sanyo 1989 unit and a 1995 Pioneer 704 player which read 1.4x discs fine, above and beyond even 140 minutes with 1.4x and 99-min CompUSA CDRs.


#19

similar to my experiences…1.3x discs (whether from premium or 716) read fine in more than 50% of my players, drives, discmans, etc…1.4x don’t…


#20

I don’t think it is a matter of 1.4x being supported in the “reading hardware” (how could 1980s vintage hardware even read ANY GigaRec disc at all, then?). It is likely a matter of 1.4x straining the tolerances of most players beyond their capabilities. I’m even surprised that many players are able to read 1.3x as well as they do (the 99:59 bug seems to be a major problem for many otherwise very high quality players, however).

It just goes to show that there is a lot of “play” in the Redbook standards. This, by extension, also must be true for the DVD standards as well. We know that, by design, they are built to a tighter spiral tolerance, so perhaps there is room for only a 20-30% “increase” in capacity by stretching the tolerances. My hat is off to the manufacturer who can figure out how to tweak this…

It may already be too late in the game, as HD-DVD and BluRay are just around the corner… But, then, GigaRec still has its place in the realm of cheap DVD-R burners…