How to downgrade and/or upgrade the BIOS of a DELL 5150 laptop without a battery

vbimport

#1

A major problem I encounterd but was able to solve with help of some topics on this forum.:cool: However I got into some slightly different additional problems and therefore I will post this next information.

I have an old Dell 5150 Inspiron laptop. It had the famous motherboard problem when I got it. I was able to repair it by soldering some 14 small pins of an IC on the motherboard and after installation of a HDD and the nescessary software it worked.

The battery is very old and had its best days. It will leave power for some 20 minutes when the AC supply is off. The BIOS has a name in it (name of a previous owner I think) which I wanted to delete or change. To start I changed the BIOS version. Actually I downgraded it from A38 (the latest) to version A29 just to see if that helped. It didn’t. And now Windows 7 did not even detect the battery. If even lost all power when I took the AC power off. So it would run only with the adaptor on 220. The battery however, looking at the lights, was being charged. Oke, probably a BIOS issue. Therefore I tried to flash the BIOS back to the latest version A38. That didn’t work. When I executed the downloaded program it stated that I had not enough rights. Didn’t make any sence. So I tried the option to download the file, copy it to a floppy and run it that way.

This is what I did:

Downloaded file I5150A38.exe from this site: http://support.dell.com/support/downloads/format.aspx?c=us&l=en&s=gen&SystemID=INS_PNT_P4_5150&servicetag=&os=WW1&osl=en&deviceid=5015&libid=1&dateid=-1&typeid=-1&formatid=-1&source=-1&catid=-1&impid=-1&typecnt=0&vercnt=14&releaseid=R90548

Put a USB floppy drive in my laptop and formatted an oldfashioned 1.44 Mb disc in DOS mode. That is the little box under “fast format” when you format a floppy under Windows. Then I copied the I5150A38-file to the disc. I turned off the laptop and had it boot starting via the USB possiblity after pressing the F12 key. Waited a few moments and got to the A disc. Typed “dir” to see what was on and it mentioned somewhere “I5150A38 EXE”. Then typed “run i5150a38.exe”. It started but finally mentioned that a battery had to be present (read, detected) to proceed and the program dit shut itself up. Then I typed the following: “run i5150a38.exe /forceit”. So, [“run” space “i5150a38.exe”space” /forceit] That worked like a charm. I got the A38 version back and the battery was detected again.:clap:

Still leaves me with the problem I started with: The name in the BIOS screen I wanted to delete. That was still present. Any suggestions?:doh:


#2

Please don’t look at the spelling. I was not able to correct it on time anymore.