How to disable Speed Change

I have Traxdata 4432 Plus and it refuse to write on all cds at 4x instead it changes speed to 2x thus making slow writer more slower.
E.g. on CDRW regardless of type writes at 4x
On CDR intended for speeds lower than 10x it writes at 4x but those intended for higher speeds it treats like 2x medium.

This feature (hopefully not bug) is present regardless to program.
Is there some way I could change that? If someone knows some firmware or program to disable that I would appreciate it. Right about now I’m prepared to do just about anything to fix this.

Sorry for bad English…

A couple of things:

-What program are you using to burn CDs? If its Nero, what version?
-Whats your writers speeds suppose to be? R/RW/Read

From what I hear, I very well may have read it wrong, sorry, how do you know what speed its writing at? CDRWs only write at speeds its suppose to, like a 4x one will only write at 4x, you can’t change it, same for 10x one. CDRs don’t listen, it depends on a couple of factors. Here’s a few things you can try in the mean time:

These are for WinXP. Well it works the same for Win2K, and the other OS can’t be too different.

  1. Update Nero to the newest version, 5.5.9.0 (Final), 5.5.9.6 (New), or 5.5.9.9 (Release Candidate).

Get 5.5.9.0 Here | Mirror | Mirror | Mirror | Mirror | Mirror

Get 5.5.9.6 Here | Mirror | Mirror | Mirror

Get 5.5.9.9 Here | Mirror | Mirror | Mirror | Mirror | Mirror

  1. Update your CD-RW’s firmware to the newest release.

  2. Go to the Control Panel, under Administrative Tools, select Services, find “IMAPI CD-Burning COM Service,” then switch it to disabled from manual.

  3. Go to the Control Panel, go to System. Select the Hardware tab, then go to Device Manager, then expand “IDE ATA/ATAPI Controllers,” go to “Secondary IDE Channel,” and make sure DMA is enabled, if it is already, but it says its in PIO mode then go immediately to step 5.

5 Follow step 4 to the “IDE ATA/ATAPI Controllers” part and delete/uninstall the “VIA Busmaster IDE Controller” (or whatever your motherboard chipset’s busmaster controller is), now reboot the pc and follow step 4.

  1. Your ASPI drivers may be bad, so try to use ForceASPI 1.7, and change it to 4.60, don’t worry, this program has the best ASPI drivers for WinXP and makes an auto backup of your ASPI drivers so you can do a rollback.

Download it here | Find mirrors here | Get more info here

7.You might have a VIA chipset, www.viaarena.com, so if you haven’t already, consider upgrading to the newest v4.42 (P2), so I recommend the stable version. If you have some other chipset, like Intel, please go to www.intel.com, and find the newest INF drivers release and also the Intel Application Accelerator (IAA), now v2.2.2.2150.

Download the latest VIA 4-in-1 drivers here

Download the latest Intel Application Accelerator drivers here

  1. Consider upgrading your BIOS

That’s all I can think of for now, please test one at a time (cept 4 and 5 tho), in whatever order you want.

Oh n please post your results,
DFourthHorseman

Thanks for reply but all the thigs you wrote I have tried before, and I meen all of them. None worked. I was hoping for a reply that would have some sort of firmware upgrade or patched firmware like for LG4x4x witch upgrades it to 8x4x.
To me any firmware that would make my 4x4x pure 4x4x would be perfect. I just wan’t to disable automatic speed cange.