How to diagnose DVD reading issues?

vbimport

#1

Hi there - I’ve got a question regarding possible issues with a new burner and its reading ability, and was hoping for some pointers in diagnosing it.

My home rig is Q6600 4GB, Vista Ultimate x64, with a Samsung SH-S223F drive. For codecs, I installed the Vista package from shark007.net.

So far all I’ve really need to do is convert some recorded TV programmes from my DVD-PVR to mp4 format using Handbrake (I was using Handbrake as there is no copy protection involved) - I’ve done this successfully.

I would like to backup some DVDs to harddisk, so I’m trying out DVDFab (on its 30-day trial license). I also would like to watch DVDs through Windows Media Center.

So far, every copy-protected DVD (I’ve tried around 10) that I’ve put into this machine seems to suffer the following problems:

  • DVDFab doesn’t recognise it, or only partially recognises it.
  • Windows Media Center takes ages to load it up, and if and when it plays it, will intermittently show artifacts on screen (looks like a tonne of screen- noise).

As a test I have put one of the DVDs into my work rig - Q6600 4GB Vista Business x64 with a Pioneer DVR-215D drive. I’ve started up DVDFab and it reads the DVDs fine. I’ll need to test playback, but the speed with which this has been picked up is far better than my home rig.

I am totally new to the world of diagnosing video / DVD drive issues. I am wondering if my Samsung DVD drive is having problems, or if the codecs I installed are somehow factoring in to the issue.

What I would like to ask is firstly is there anything obvious in the symptoms above, and secondly how could I diagnose the apparent issues.

I would appreciate any advice or pointers to apps/articles that might help.

Many thanks,

Ali


#2

Try playing the dvds in VLC media player. It is self contained and does not rely on outside codecs. http://www.videolan.org/ If you don’t want any file types associated with VLC, you can choose not to do that as you install it.

Which motherboard are you using? Some onboard SATA controllers are a bit problematic when using SATA optical drives, but yours sounds new enough that this shouldn’t be a problem. You have the latest chipset drivers for your board installed?


#3

Hi Kerry56,

Thanks for the reply - I should’ve tried VideoLAN as a matter of course! I’ve tried the DVDs in VideoLAN and I get the same problems. Sometimes I can get the DVD Menus to come up but then nothing afterwards will play. VideoLAN doesn’t give me any errors, apart from the occasional one telling me (eventually) that it failed to play the dvd menu.

My m/b is an MSI P35 Neo2-FR - I’ve just flashed the BIOS with the latest version, but I don’t know how to do anything with the onboard SATA controllers. The BIOS flash hasn’t improved the situation. I’m trying to play a DVD at the mo through VideoLAN and I can see the DVD drive read light coming on occasionally for a few short bursts with a minute or so between bursts

So is this sounding like the DVD drive could be the likely culprit, or is it more likely to be a driver issue?

Thanks for your reply so far!

Ali


#4

Are your SATA controllers in IDE emulation mode or AHCI? IDE mode seems to work for optical drives, but is limiting. Switching to AHCI once the operating system is installed can cause some serious problems. http://en.wikipedia.org/wiki/Advanced_Host_Controller_Interface

The latest Intel drivers for the ICH9R can be found here

I’m still working from the side that it might be drivers rather than the drive itself. You have one SATA port that is controlled by the Marvell controller rather than the Intel. Is the Samsung drive connected to it or to the Intel ports? Have you tried switching the cable to another port?

The next thing to try is hooking up the Samsung to your other computer and testing it there.


#5

Hi Kerry56 - thanks again for the reply.

The SATA controller is IDE - I’m not sure I fancy trying to switch it to AHCI , seems rather daunting. The device is plugged into the Intel ports and not the Marvell port. I’ve changed port and cable with no joy.

I probably wasn’t too clear on another symptom. In my OP I mentioned being able to read discs burned from my PVR. Well, I thought I might revisit that tonight. What I tend to do is record a load of programmes off the TV onto my HDD/DVD PVR, and then I want to get some of them onto my iPod. So I burn the DVD and use Handbrake to rip it and convert it in one go.

In the past this has worked fine with no problems - the last time I tried would’ve been about 10 days ago. I’ve just grabbed one of the those discs and now the drive can’t read it. I can’t see the VIDEO_TS folder - it just hangs.

The only change that I’ve knowingly made to my system (other than today’s BIOS flash mentioned above) is the raft of updates that MS released this week.

I’ve got to say that the drive seems to not even get DVDs spinning to full speed (well, that’s what it sounds like to me - when it sounds like it’s whistling before settling bck down to a hum).

I’m going to try taking the drive to work and try it on my work rig, although that may well have to wait til Monday.

Thanks again for your help.

Ali


#6

Just as a follow up. I put the drive into my work rig and it came up with the same problems. I tried my work DVD drive in my home PC and it’s working fully.

I’m going to get a replacement drive, so if it is a driver issue associated with the SH-223F I’ll can find out that way.

Thanks for your help and advice. Much appreciated…

Ali


#7

Its just a bad drive then. Glad you got things under control.