How to change ECC on 3540A

vbimport

#1

I did a search on here and only came up with 1 thread that mentioned something about changing the registry keys to change from 8ECC to 1 ECC.

I am not sure how to do this. Can someone break it down for me. Thanks!


#2

How about reading the first post in the firmware threads…


#3

Ive seen that one before. It directs you to another forum with a ton of different posts. how about being more specific.


#4
REGEDIT4

# Scanning Interval
[HKEY_LOCAL_MACHINE\SOFTWARE\Ahead\Nero Toolkit\CD Speed\CD Quality]
"Scanning Interval"=dword:00000002

# NEC's scanning intervals, is the desired interval + 1, i.e. a
# scanning interval of 8, should be 9 (8+1), 1 should be 2 (1+1) etc.
#
# To compare with other drives following intervals can be used:
# 8  ECC (to compare with BenQ/Philips/QSI/Pioneer)
# 1  ECC (to compare with LiteOn/BTC/Plextor)
# 32 ECC (to compare with AOpen)

#5

Mine is set to 1, ie “Scanning Interval”=dword:00000001, so does Quikee’s here. hmm…


#6

I believe the Nec Scanning Interval Bug is mentioned in Dee and Liggy’s firmware notes.

Originally Posted by ErikDeppe
I haven't been able to test this myself but it seems that NEC fixed a bug with the scanning interval.
To change the scanning interval with Nero CD-DVD Speed the following registry value can be added:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\ahead\Nero Toolkit\CD Speed\CD Quality]
"Scanning Interval"=dword:0000009

Anyway, you can read more about it here;
http://forum.ixbt.com/0031/021744-6.html#162


#7

Thanks for all the help. I modified the registry to 00000001.

My NEC is now scanning at 1 ECC.

Thanks again…


#8

After a lot of Russian-to-English Babelfishing, I’ve come to the conclusion that the ECC setting -1 (minus one) to overcome the NEC scanning Bug, only applies to Nero CD-DVD Speed pre v3.80.
That means if you’re running post-3.80 (for example the newest version, v4.01), you should use 1 as 1, and not 2 as 1 as earlier.

REGEDIT4

# ECC Scanning Interval of 1
[HKEY_LOCAL_MACHINE\SOFTWARE\Ahead\Nero Toolkit\CD Speed\CD Quality]
"Scanning Interval"=dword:00000001

#9

can someone please help me. i wanted to change the ECC on my 3540a but there is no " scanning interval" in my registry. at HKEY_LOCAL_MACHINE\SOFTWARE\Ahead\Nero Toolkit\CD Speed\CD Quality

after “sample length” is “secondary grid color”. scanning interval is just not there. is this bad, what does it mean. thanks for the help


#10

You have to add it - right click (on right side) and choose new - then DWORD value - call it Scanning Interval. Then double click the new DWORD and change the value data.


#11

how about a little script action???

unzip and run.
options are 1 , 8 , 32
anything else has no effect
by using this script you are agreeing that i have no liability for anything that happens or doesn’t happen’
want to see what it does right click and edit the vbs file

if your AV asks have it allow the script

i know F*ck-all about error trapping in vbs. the script is something that i stole and bastardized to do this (it was for something far different originally)

any one who can, feel free to upgrade it to make it nicer

change interval.zip (661 Bytes)


#12

thanks for the help, i did it the old fashion way and added manually like dewd2 said to. it has worked as nero cd speed after completion of a scan shows 1ECC in summary. anyway, heres my first scan with the new changes. its staples dvd+r burned at 8x which is CMC. doesnt look too bad.



#13

cnlson,

Thanx for the script. This works great for v3.8 where you need +1, but won’t work for v4.0 so I made a slight change. It should now work properly for v4.0!

change interval v4.zip (666 Bytes)


#14

thanks! i guess i didn’t read close enough :slight_smile: