How to avoid PIO mode

vbimport

#1

When using Fab Platinum to rip I sometimes have a scratched disk which I usually don’t know about until the read portion starts to slow down or stop…
The program temporarily freezes at some point in the reading and it seems to always throw my Burner into PIO mode which I then have to do the remove secondary channel/reboot in order to get me back to Ultra DMA4.

I know the what and why reasons for The Microsoft kickdown to PIO mode but is there anyway I can avoid this happening when Fab runs into a scratched disk?

Is there any read errors setup in the software that I can set it to so as to possibly catch it before the alloted error retries or similar so that I can stop the session before it puts me in PIO Mode or is that not a option?

I quess a simpler way to put it is can u stop a scratched or deffective disk from putting you into PIO mode…


#2

Since this is an OS function, I don’t think you can prevent it, not altogether.
Personally, in all my years of burning dvds, I’ve never experienced the dreaded PIO mode and I’ve had my fair share of bad and unreadable discs.

You could limit your exposure to CRC errors by enabling [B]ignore all reading errors automatically[/B] in Fab, but the downside is you may well copy a bunch of gibberish. Again, when I’ve done this, I’ve never had a problem, but it usually did not help either, although occasionally, it ground its way through.

I almost exclusively use Liteons to read as they are outstanding readers and I think this may help, but I don’t believe it’s as simple as this.

You could try running the VBS Script file (link in my sig in case the zip file fails) and you may find that the DMA mode will “stick” better.

Worth a try.

resetdma.zip (1.21 KB)


#3

Thanks…

I use Plextor 716A burners which were the creme dela creme few years ago…

I’ll try your script file…
what exactly does it do?


#4

Essentially an “automatic” or alternative method to using regedit.
The article in my sig does a decent job by way of explanation.
It’s a more permanent and reliable method of resetting DMA mode than some of the alternatives such as the reset button in Fab.


#5

the “reset dma file” states for all ATA drives.

My burners and hardrive are IDE…

does this matter?


#6

[QUOTE=rago88;2152260]the “reset dma file” states for all ATA drives.

My burners and hardrive are IDE…

does this matter?[/QUOTE]

ATA is a more utd term.

§ ATA = Parallel ATA … [I]PATA is often used synonomously with IDE[/I]

(S) ATA = Serial ATA

The VBS Script file is ok with both PATA and SATA drives. Many SATA drives need to have DMA enabled if they’re set up as IDE in the bios.

You’re fine…:wink:


#7

Based on my own experience make sure you have 80 conductor data cables, in good shape, on the drive(s) and keep them as short as possible.


#8

Iv’e had my computer drop down to PIO mode once before. It happened when I was going through my cd collection and some weren’t so nice. That was using MediaMonkey to rip them.


#9

[I]You could try running the VBS Script file (link in my sig in case the zip file fails) and you may find that the DMA mode will “stick” better[/I]

Mainman,

thanks for the file…
It reset my DMA just like you said…
Don’t know yet if It will make my DMA more stable but It is now a shortcut on my desktop and much quicker to use it than to go into properties, remove/re-install my secondary channel.

I had just finished backing up a couple movies this morning, [U]This was before I used [/U][U]your zip file, [/U]] left my Pc for 30 minutes, came back and needed to make a copy of a backed up movie. '[Transformers].
I put the backup disk , clicked on Fab, and the "you need to reset your settings to DMA came up…
checked my hardware and sure nuff… “the dreaded PIO mode”…
what the hell!!!
I just finished backing up 3 disks and it came outta nowhere…
oh well.
will see if it helps to keep my DMA a bit better.
Thanks again for the file…


#10

i know you have had this problem for awhile now. have you looked into hardware issues? have you gotten a new ide cable? have you tried different ripping drives? have you tried uninstalling your ide controller? [as ive recommended before with no response.]

its strange that your system does this. :frowning:


#11

I did replace the 80 pin cable a while ago…

this seems to occur [ maybe coincidence] soon after I have updated to latest version of Fab, beta or stable…

this is not an everday occurence but even once every few weeks seems alot to me…

no, I still was un-installing the secondary IDE channel when PIO occurred, not the Ultra storage IDE channel…