How to access the modem?

vbimport

#1

Hi :slight_smile:

D-Link 655, the router I recently installed, is a router only, so I have to use a separate modem.

The problem is that I can access the router configuration pages only, but there is no way I can access the modem config pages.

The only way is to disconnect modem and connect it to the computer NIC directly.

I don’t know if I set IP for each device correctly, but I read somewhere that router and modem must have a different submask, so:

Modem IP: 192.168.x.1
Router IP: 192.168.y.1

(IPs are not the ones I’m using, it is only an example).

With these settings, the computer NIC must be 192.168.y.2, i.e. it must have the same submask of the router.

But because of modem and NIC have different submasks, I can’t access to the modem config pages.

There is a way to solve this or I have to disconnect modem, change NIC IP and connect the modem directly to the PC?

Thanks :slight_smile:


#2

There should be a way of doing it, but if it were me I would just connect it directly. You shouldn’t have to configure it more than once or twice. :slight_smile:


#3

You should have it in bridge mode (transparent), not NAT…
//Danne


#4

Thanks for answers :slight_smile:

[QUOTE=eric93se;2539735]There should be a way of doing it, but if it were me I would just connect it directly. You shouldn’t have to configure it more than once or twice. :)[/QUOTE]

The reason why i need to access the modem is not to change settings, but to see details about the connection. Sometimes (because my ISP suxxxx) I notice disconnections, and often when this happen I notice that after reconnection my speed is very slow, so I’d like to see for details.

These information are not available from the router :doh:

[QUOTE=DiiZzY;2539739]You should have it in bridge mode (transparent), not NAT…
//Danne[/QUOTE]

The modem is already set in bridge mode but when I type the modem IP on browser I can’t load the config pages :frowning:


#5

It works on UK Virginmedia cable modems, but the “gate” is only open when the modem is online, the same situation may be true on others. When offline, only an in-subnet address can access.

Alternatively, you could try putting the router to 192.168.x.2


#6

[QUOTE=Matth;2539773]It works on UK Virginmedia cable modems, but the “gate” is only open when the modem is online, the same situation may be true on others. When offline, only an in-subnet address can access.

Alternatively, you could try putting the router to 192.168.x.2[/QUOTE]

Thanks for suggestion :slight_smile:

I read somewhere that router and modem must have different submask, so I never thought to try this :doh:


#7

[QUOTE=geno888;2539884]Thanks for suggestion :slight_smile:

I read somewhere that router and modem must have different submask, so I never thought to try this :doh:[/QUOTE]

Not sure, now, could end up confusing with DHCP etc.

As I said, only ever seen it where they gate/bridge automatically, maybe there is some setting in the router that will allow/prevent private IP range traffic being forwarded to the WAN interface.

http://homepage.ntlworld.com/robin.d.h.walker/cmtips/ipaddr.html
The tip here of adding a second IP to the interface (multihoming) is only applicable to direct connections, also describes the way many cable modems sniff their config IP on the outgoing side, hence this bridging only works when the modem is connected ok.


#8

Update.

I tried but it didn’t work. I wonder if it is something in the router itself that doesn’t allow me to access modem. Maybe I set something wrongly :doh:


#9

With modem in bridge mode accessing it can only be done if the modem is directly connected to the computer if I recall correctly. One solution to the problem is to configure the modem in router mode and then reconfigure the router. This is what I did on my system for the same reason, i.e. access both modem and router without fiddling with disconnecting and reconnecting cables.


#10

[QUOTE=bevills1;2540334]With modem in bridge mode accessing it can only be done if the modem is directly connected to the computer if I recall correctly. One solution to the problem is to configure the modem in router mode and then reconfigure the router. This is what I did on my system for the same reason, i.e. access both modem and router without fiddling with disconnecting and reconnecting cables.[/QUOTE]

How can a modem be configured as router? I’m not sure that this is possible with my modem.

btw, if I set the modem as router, is the router itself still necessary?


#12

Apart from the initial setting up of a DSL modem, generally the only time one needs to access the modem GUI is when changing ISP or to check the DSL connection technical info, such as in the case of an unusually slow or unstable Internet connection. All other configurations such as port forwarding, DHCP, Firewall, traffic/usage monitoring, QoS, Wi-FI (depending on spec), etc. are carried out on your router.

So I wouldn’t worry about not being able to access the modem’s GUI, unless you find yourself changing ISPs regularly or need to monitor the DSL technical info. I know some non-DSL modems such as cable, satellite, fixed wireless and WiMax modems often don’t have a user accessible GUI or is password protected by the ISP. They simply do no more than provide the physical Internet connection, usually to the WAN port of the consumer’s own router.


#13

Thanks for the info :slight_smile:

The reason why I’d like to see modem config pages is that router doesn’t allow me to see technical details about the current connection.

I remember when using the old Linksys that rather often, after a disconnection, I was connected again on a slow line, and the only way to remedy was disconnect phone cable and waiting for a new connection.

With the modem + router system, I can’t check this information anymore :doh:


#14

The following should work (I’ve done this before), but it’s a little messy:

You will need a spare network port (e.g. second network card) in your PC and a spare network switch, unless your modem has two or more ports.

The router and modem need to be on separate subnets. For example, if your LAN computers, devices, etc. are configured with 192.168.1.x, then your modem must have a different second last octet, e.g. 192.168.2.1.

[ol]
[li]If your modem has 2 or more ports, connect the second port directly to your PC’s spare network port and and skip to step 4.
[/li][li]Connect the modem to the switch and another cable from the switch to the WAN port of your router.
[/li][li]Connect your PC’s spare network port to the switch.
[/li][li]Configure this network port with a fixed IP on the same subnet as your modem’s IP. For example, if your modem is 192.168.2.1, configure this network card as 192.168.2.2. Subnet mask is 255.255.255.0. The DNS and gateway fields should be blank.
[/li][/ol]

Now you should able to access the modem’s interface GUI on that PC as well as have Internet connectivity.

The following MSPaint job gives an idea: :slight_smile:



#15

Many modems may be configured in either router or bridge mode, but a few are bridge only mode like a Efficient 5360 I once used. You should be able to get details on your modem from the manufacturer’s web site or maybe from your ISP if the ISP provided the modem. Support for your modem should be able to help configure it in router mode if it’s not a bridge only modem. A router is still needed if modem is in router mode because the router transmits wireless signals while a modem does not.


#16

Thanks for suggestion Seán :bigsmile:

I’ll try this soon. I have to check if I have enough net cables :bigsmile:

I have also to get a second switch because currently I have only one


#17

That has to be the most stupid network layout I’ve ever seen for multiple reasons…

  1. It makes the DIR-655 useless (at least put it in AP mode)
  2. The modem will most likely (95% sure) choke if you start doing P2P
  3. Your connection will crawl since it doesn’t do QoS like the DIR-655 does

If your connection sucks call your ISP and have them fix it or your telco.

//Danne


#18

[QUOTE=geno888;2539731]Hi :slight_smile:

D-Link 655, the router I recently installed, is a router only, so I have to use a separate modem.[/quote] So you got a router and a modem. Check

The problem is that I can access the router configuration pages only, but there is no way I can access the modem config pages.
Probably since you have used DHCP on your pc. It took the router as the gateway.

The only way is to disconnect modem and connect it to the computer NIC directly.
Yup, your pc DHCP requests will now get an ip from the modem.

I think this is almost guarantueed proof that both router and modem are dhcp servers.

I don’t know if I set IP for each device correctly, but I read somewhere that router and modem must have a different submask, so:

Modem IP: 192.168.x.1
Router IP: 192.168.y.1

(IPs are not the ones I’m using, it is only an example).

If you want to have two DHCP servers, then yes, have two different subnet masks. But you don’t need it for this configuration.

But because of modem and NIC have different submasks, I can’t access to the modem config pages.
Correct

There is a way to solve this or I have to disconnect modem, change NIC IP and connect the modem directly to the PC?
As already mentioned, set your modem in bridged if your modem is also a router. See the D link support faq for all the info.

@Sean; that’s a very expensive and messy way to just see a setup screen of the modem. I think it will work, but i also think that DiiZzY is right. :slight_smile:


#19

I can’t remember off hand the DHCP settings for modem.

In the router I left almost everything as default, and indeed the option “Enable DHCP Server” is checked.

Should I disable DHCP both in modem and router then?


#20

Not in both, unless you want to use fixed ip addresses constantly.

I’m not sure what would be wise here, because of the wireless part.


#21

I must confess that I never tested the wireless part of my new router… I very rarely use wireless actually :doh: