How I fixed my Liteon 832S

vbimport

#1

The drive was doing very bad things, burning rings on various media, doing very bad burns, causing lots of CRC errors, high PI and PIF counts on very good media.

In a final act of desperation I burnt a disc (CMC MAG E01 of course) and deliberately caused buffer underflow quite a few times so that the drive would stop / start over and over (my Canon flatbed scanner uses the parallel port, and when you do a scan the whole computer grinds to a halt).

At the end of the burn, the result was perfect again.

I guess I’ve done about 10 burns since then, using an assortment of media, and not had a single bad burn.

I don’t know how or why this has worked, maybe some of our armchair experts might like to comment?

Sample burn since being fixed:


#2

How odd! There’s a lot of quirks about the LiteOn drives that are not well-understood…


#3

Can you explain what you did, I’m not sure. Are you saying you deliberately tried to mess up a burn, and then all burns were ok? My drive is behaving exactly like you describe, with bad burns, missing rings, etc. I’m probably going to exchange it.


#4

An easy way to achieve what I achieved would be to set the burner access to PIO mode 4 instead of DMA enabled, then do a burn. This should cause buffer under-runs and hopefully “unstick” the drive.


#5

When my liteons started doing that i just RMAed them thanks for the tip if i ever see that again ill try it.


#6

Guess it could be cause it moves it slower over the alingment maybe it smears grease and crud more evenly or just cleaned it out??

how strange…


#7

It’s not even remotely likely that what you did had any effect on the drive.
You could just as easily say that you performed some incantation during the burn and that fixed it. You’ve reported many times that this drive has “intermitent” problems. It’s far more likely that it has just decided to behave for a while, or that some other variable has changed.


#8

I think the drive does try to do a bit of “learning”. And every now and then, this can go astray and it “learns” something bad. Often, the quickest way, in my experience, to get it to “unlearn” something is to revert back to an older EEPROM from when the drive was working top-notch.

Of course, this is all speculative, as there has been no solid evidence of such a learning procedure…


#9

Very odd things happening with your drive there Jackass.
Good to see it is working again for you.
This goes to show that one should not jump to conclusions so fast and put the blame on speedhacking/strat swapping for “killing” a drive…


#10

I knew a few armchair experts would chime in with their good wishes.

So far 1 moderator and 1 ex moderator have left me underwhelmed.

At least both of the Codeguys tried to help, that is what being a moderator is all about isn’t it?

Some moderators need to re-examine their positions in life.


#11

Now this post is aimed at Mr Grimes.

During the burn where I deliberately caused buffer under-run on numerous occasions, the drive must have become confused, because it burnt a ring at a different position (see the scan below)

For this to have happened, something MUST have changed in the drive, and that is why it’s working properly now.



#12

yeah, i had my Lite On take the CCIE practical exam in San Fran @ Cisco’s HQ for me last week, and it passed!


#13

For this to have happened, something MUST have changed in the drive, and that is why it’s working properly now.

You could just as easily claim that because it rained in Berlin on the same day, that rain in Berlin will fix a drive.
In order to draw a conclusion from ANYTHING, it must be demonstratable and repeatable. If you had done nothing to this burner from the day you got it, it could easily have demonstrated all the same problems. As to the rings on your discs, they could be due to any number of causes, not the least of which is using the wrong write strategy. (as a result of swapping strats). The one thing we know for certain about the LiteOn burners is that they are unpredicatable. Jumping to conclusions based on un-verifiable and probably unrelated events just perpetuates the confusion.

My advice is to re-flash your original EEPROM, and download a fresh copy of the appropriate firmware and flash that. Then leave your drive alone for a while and see what it does. If it behaves for 20 or 30 burns, then you know there is nothing wrong with the hardware, and probably never was.


#14

I think I’ll close this thread before things heat up too much. Sorry guys.