How does one flash in DOS? (NEC 2510A DVD-RW)

vbimport

#1

I have a NEC2510A drive which I would like to flash with the Herrie’s 1.07 v2 beta 5 (if your familiar with it). Anyways, I don’t have a floppy drive, so my other option would be burning the firmware on a cd. If someone knowledgable in this area would direct me through this proccess I would be very appreciative. Thanks!


#2

Go to http://pioneerdvd.rpc1.org/ and find the section towards the very end labeled the “The Firmware Flashing Bootdisk” This can be used for firmware flashing in general and not just for Pioneer flashing. There is both a floppy version and a CD-ROM version.


#3

So here’s what I understand, and what I plan to do for the flashing proceedure:

  1. Burn the bootdisk.iso file onto a CD-R
  2. Download the 2k5107v2b5dld.rar file (DOS firmware), and place in a folder on the hard drive.
  3. Place bootdisk.iso CD into DVD-ROM (happens to be the only ROM installed)
  4. Restart the computer, enter BIOS and select “boot from CD-ROM”

here’s where things get a little hazy…

  1. Navigate in DOS to find the firmware file, and use to flash the DVD-ROM (how?)
  2. Wonder if I forgot something? (DOS flashing utility? what is that?)
  3. Restart and hope it worked?

If someone could fill me in with the parts I’m unclear about, I would appreciate it so I don’t screw up my drive. Thanks


#4

The flashing utility is the .exe file that does the flashing of your firmware… you just need it and the firmware update file in the folder on your drive.

In my case the command was: C:
ec2x00a -pri -mas -flash 2510orig.BIN (I just put the 2 files in my c drive)

Note that this includes the flashing utility (nec2x00a) the location of your drive to be flashed (-pri -mas) and the actual comand to flash (-flash 2510orig.BIN)… you will substitute 2510orig.bin for the actual name of your firmware update file.

Hope this helps.


#5

This cleared up the process, Thanks Matt.

However, I can’t seem to successfully boot my PC from a CD-ROM (running windows XP). I tried two downloaded .ISO images, neither worked. Then I attempted using http://www.nu2.nu/bcd/ to build my own bootable CD (which is supposed to result in a .ISO image) with no luck. This somehow seems more difficult than it should be, please shower me with your solutions. Thank you


#6

Disregard the last post, I used Nero to “burn image” and got the boot disk.

Now I have the most random roadblock, I can’t type a goddamn backslash in DOS… it for unknown reasons replaces the ( \ ) with a ( # )… I have no idea why. How am I supposed to run

D:
ec2x00a -sec -mas -flash 107v2b5d.bin

without a BACKSLASH? freak-a-leak…


#7

First, are your files on the D drive? (is D the hard drive or the CD-ROM?) One point about using the boot disc is that it allows you to access your hard drive even if you use NTFS, so you can make use of that.

Second, you don’t need to specify the path like that. For example, if both the flasher and the firmware are on the C drive in the root directory, then you can just change into the hard drive patch first like this:

C:   <ENTER>
nec2x00a -sec -mas -flash 107v2b5d.bin   <ENTER>

#8

My hard drive is the C drive (with the firmware file) and my D drive is the DVD-RW (which I am using for both the bootdisc and subject of the flashing, is that a problem?). I just assumed that I should be in the drive which the DVD-ROM is set to, but I guess that’s why you specify what to flash with -sec -mas.

I just tried both of these commands in DOS while in C:> (hard drive)

nex2x00a -sec -mas -out BACKUP.BIN (backup original firmware)
nec2x00a -sec -mas -flash 107v2b5d.bin

Both resulted in [Bad command or file name].


#9

I hope you typed NEC…not NEX… and secondly are you sure your flash utility and your firmware update were in your C drive.


#10

Sorry, I meant nec, that’s what I typed in DOS.

I have my firmware update in C:/Program Files/NEC Firmware/107v2b5d.bin

As far as the flash utility, it was explained to me that the flash utility is the .EXE file packaged with the firmware update .BIN file. Based on that I unpacked the .rar package into my NEC Firmware folder which now contains 107v2b5d.bin and NEC2X00A.EXE. Perhapes I need to be more specific so my PC can find these files, or include the .EXE extension when running the flash command…

An interesting thing I just remembered which may be of importance - When in Windows my harddrive is shown as C Drive, and DVD-ROM as D Drive. Now when I entered DOS with the bootup CD it verified my DVD-ROM as the D Drive. However, when I typed
C: [enter]
dir [enter]

I got files which do not resemble anything like my recognizable C Drive. When I typed
D: [enter]
dir [enter]

I got my Program Files folder, Games folder, System folder, ect… which looked exactly like my C Drive. I don’t know why this is or what it may affect, but either way I am unsure where to go from here.


#11

Oh. Well, drive letter mappings can be different in Windows than in DOS. It’s just odd because C almost always is mapped to the HDD no matter how you booted up. Well, no matter, if your HDD gets remapped to D: when you’re booted in DOS, then use D: instead of C: when in DOS. Anyway, if your files are in Insert_Hard_Drive_Letter_Here:\Program Files\NEC Firmware, then you should be doing:

CD PROGRA~1 <ENTER>
CD NECFIR~1 <ENTER>
NEC2X00A blah blah

This is because when you type that command, it’s looking for the files in the current directory (the root directory) and not in the Program Files directory. You’ll have to change the current directory to whereever you keep your files before this would work.

Or alternatively, it’ll just be easier to keep your files in the root directory of C: instead of somewhere in Program Files so that you don’t have to issue all those directory changing commands.

Googling up a tutorial for DOS could be helpful here.


#12

I have a NEC 2510A and I have been looking for this update,can you tell me were it is?


#13

The stickies in the NEC forum would be a good place to look. :wink:


#14

Thank you Code, I should have tried putting them directly in the C: folder in the first place, but nobody seemed to think it was of any importance.

I tried the backup prompt in D: [nec2x00a -sec -mas -out BACKUP.BIN], hit return, and got only a curser two lines below my typed promt. I waited 5-10 minutes and nothing happened, and I couldn’t type anything so I restarted my PC. I couldn’t find a BACKUP.BIN file anywhere on my computer so I’m assuming it didn’t work. I’m reluctant to try the -flash command, as I don’t want to ruin the drive my restarting during the proccess. Please post any ideas to solutions. Meh. Thanks guys


#15

I have a smaller problem, just flahsed my NEC ND2500A with something to make it region free, dont remember the file exactly and its reg free now ok, but when i flashed with latest firmware v1.07 he x8 speed isnt showing anymore on nero burning rom and not even onx4 it can burn on princo im getting POWER CALIBRATION ERROR at 1%, can anyone help to from where to get the herries lastest firmware?? im getting PAGE Error Displays, or could anyone send me the firmware via e-mail pls??? digitalscar@hotmail.com or videostar@global.net.mt cheers guys


#16

Stop using Princo discs.


#17

Yo-

Why are y’all going thru so much angst trying to flash in dos? - I did Herries windows flash on my 2500, 2510 and 3500 in no time and it worked just fine (in XP Home)-

Took all of 2 minutes including the reboot!!

Happy Burnin’

Mike


#18

Because my NEC 3500 is inside my Linux box and not my Windows box.