How do you use the VOB Passthrough?

In this post on the TiVo Community forum Singals2 said you can use the VOB Passthrough method to create Mpeg files from DVDs that are usable by TiVo.

I’ve searched this forum, I’ve looked around the interface, there is no tutorial for this software. I can’t figure out how to use a “Vob Passthrough”. I see a profile in the DVDFAb directory that is entitled VOB Passthrough but I don’t know how to access that profile from within the DVDFab Platinum interface.

Can somebody tell me how I can create a .Vob file from a DVD using DVDFab Platinum using the Vob Passthrough method? Or could you link to something on the web that explians this.

Many Thanks.

…Dale

Hi Dale, it’s me. (My username was taken over there). VOB Passthrough can be accessed two ways: First is as the bottom choice in the Generic Device drop down, the second is to add it as a standalone device using the Customize UI in Common Settings (click the little gear icon to access). This profile (VOB) has no user settings but should work with the TiVo software for most NTSC Region 1 DVDs. The files will be big. I will try to make some TiVo profiles for H264 or MPEG-4 over the weekend.
When DVDFab finishes, just change the file suffix from .VOB to .MPG if that is what the Tivo likes.

/EDIT/ This post has a screen capture that shows the Generic location.

Thanks signals. I figured out your first method - Gosh, I never would have figured that out had you not mentioned it to me.

As for the second method, that took more hunting. For the benefit of other TiVo users, here’s what you need to do after clicking on the Cog:

  • click on the CUstom UI under the General “tab”
  • Click on the “New” button under “Option”
  • Click on the Vob option that appears in the Available Options
  • Click on the “>>” to move it to the Options to Display window

for this to show up. Again, I never for the life of me would have found this without your suggestions.

Thanks So much.

And, yes, two new “TiVo Mpeg2” and “TiVo Mpeg4” profiles would be a Huge benefit to us TiVo folks. We just need to explain how to get them into the interface. I guess I just did that above … I’ll link to this thread again in the TiVo Community Post.

I don’t mind the large Mpeg 2 file for now. I won’t keep it long. Just long enough to transfer it to my TiVo S2 then I’ll delete it off my PC because I could recreate it any time I needed.

Once the S3 supports file transfers from the desktop to the TiVo (supposed to be any time now), I’ll redo it all with your Mpeg-4 profile.

I REALLY appreciate the help!

Thanks so much.

…Dale

Your’re very welcome. Hope the VOBs will go in and be converted OK. I will try to do the new profile so that you can install it as a device (as you did correctly with VOB Passthrough). You will need to move something to the left pane in the UI to make room. An official User Guide will be available soon.

Thanks, I did move a couple things to the left.

I just finished an end-to-end test. It worked FLAWLESSLY and the resulting video is pristine - limited only by the S2’s S-video output. I expect that once this is set up for the S3 (ie: once TiVo supports this on the S3 as they promised for this fall) it will be stellar quality with the HDMI/component outputs.

Also, as the user over at the TiVoCommunity pointed out, this was MUCH faster both in the ripping with DVDFab and transferring from my PC to the TiVo S2 as there was no transcoding required at any step. MY PC’s 4 virtual cores are very greatful!

…Dale

Hi. Found my way here via this thread over at tivocommunity.com.

First off… thanks to Dale and Signals for working through this. I downloaded the trial version of DVD Fab Platinum and started playing around with some of the DVDs in my collection to see if I could produce TiVo-friendly Mpegs in one easy step. I got things working via VOB Passthru (thanks to this thread) but, I’m getting some odd results in many of the videos I tried. The resulting Mpegs seem to be ok but, when I transfer them to TiVo, they don’t work quite right. I believe the entire file is transferred to the TiVo (and is playable for the most part) but, the TiVo seems to be “confused” about the length of the video. For instance, I created a Mpeg which was approx 1h47m long but the TiVo seemed to think it was only 1h11m. While the file continued to play after the 1h11m mark, any of the controls (fast forward, rewind, etc.) worked erratically and I couldn’t stop/restart after that point (because TiVo thought I was at the end). Bottom line, it appears that TiVo doesn’t like files that don’t accurately report their length.

I had used a slightly more complex process to do the same thing in the past which consisted of using DVDFab HD Decryptor to pull an appropriate title off of a DVD and then VOB2MPG to merge the resulting VOB set into a single mpg. I ran the same DVD through this process and the resulting mpg transfered to the TiVo as expected, reported the correct length, and played as expected from beginning to end.

I used MediaInfo to compare the Mpegs produced from the same DVD title using the two methods above and found some inconsistencies (esp. in the reported PlayTime). I’ve included the info from MediaInfo below.

I’m not sure if there is anything to be corrected or if the TiVo is just being “picky” about the Mpeg files but, I figured I would share my experience just in case.

Thanks.

One other note: the latest TiVo software (9.1) seems to have introduced some changes/bugs into this portion of the software. If nothing else, it seems to be more “sensitive” to these types of inconsistencies in files that are sent to the TiVo. It may not be significant to this conversation but, it could be playing a role and felt it was worth mentioning.

[B]Output from MediaInfo[/B]

[U]Method 1: DVDFab Platinum VOB Passthru[/U]

General #0
Complete name        : D:\video_dvdfabplatinum_vobpassthru.mpg
Format               : MPEG-2 Program
Format/Family        : MPEG-2
File size            : 4.02 GiB
PlayTime             : 8ms
Bit rate             : 30 Mbps

Video #0
Codec                : MPEG-2 Video
Codec profile        : Main@Main
Codec settings/Matri : Custom
PlayTime             : 284ms
Bit rate             : 9800 Kbps
Bit rate mode        : CBR
Width                : 720 pixels
Height               : 480 pixels
Aspect ratio         : 16/9
Frame rate           : 29.970 fps
Standard             : Composite
Chroma               : 4:2:0
Interlacement        : Interlaced
Bits/(Pixel*Frame)   : 0.946

Audio #0
Codec                : AC3
PlayTime             : 1h 11mn
Bit rate             : 448 Kbps
Bit rate mode        : CBR
Channel(s)           : 6 channels
Channel positions    : Front: L C R, Rear: L R, Subwoofer
Sampling rate        : 48 KHz

[U]Method 2: DVDFab HD Decrypter & VOB2MPG[/U]

General #0
Complete name        : D:\video_dvdfabhddecrypter_vob2mpg.mpg
Format               : MPEG-2 Program
Format/Family        : MPEG-2
File size            : 4.03 GiB
PlayTime             : 1h 47mn
Bit rate             : 5350 Kbps

Video #0
Codec                : MPEG-2 Video
Codec profile        : Main@Main
Codec settings/Matri : Custom
PlayTime             : 1h 47mn
Bit rate             : 9800 Kbps
Bit rate mode        : CBR
Width                : 720 pixels
Height               : 480 pixels
Aspect ratio         : 16/9
Frame rate           : 29.970 fps
Standard             : Composite
Chroma               : 4:2:0
Interlacement        : Interlaced
Bits/(Pixel*Frame)   : 0.946

Audio #0
Codec                : AC3
PlayTime             : 1h 47mn
Bit rate             : 448 Kbps
Bit rate mode        : CBR
Channel(s)           : 6 channels
Channel positions    : Front: L C R, Rear: L R, Subwoofer
Sampling rate        : 48 KHz

Hello to all TiVo users that have found their way here. Rjmitchie, I tried a (single chapter) passthrough with the current version of DVDFab and got normal results with MediaInfo:

Desktop emp\subtest\vob\THE RAINMAKER SCE\THE RAINMAKER_VOB.vob
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 148 MiB
PlayTime : 4mn 42s
Bit rate : 4380 Kbps

Video #0
Codec : MPEG-2 Video
Codec profile : Main@Main
Codec settings/Matri : Custom
PlayTime : 4mn 42s
Bit rate : 9800 Kbps
Bit rate mode : CBR
Width : 720 pixels
Height : 480 pixels
Aspect ratio : 16/9
Frame rate : 29.970 fps
Standard : Composite
Chroma : 4:2:0
Interlacement : Interlaced
Bits/(Pixel*Frame) : 0.946

Could you try just a short rip with a different disc and see what it reports?

Thanks for the quick response signals. For the record, I’m using DVDFab Platinum 3.2.1.0. I should also mention that not all titles exhibit the behavior I am seeing, but many/most of them do.

As suggested, I tried a short rip (main movie-single chapter) with a different disc and saw normal results as you did:
General #0
Complete name : D:\video6_dvdfabplatinum_vobpassthru.mpg
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 154 MiB
[B]PlayTime : 4mn 43s[/B]
Bit rate : 4549 Kbps

Video #0
Codec : MPEG-2 Video
Codec profile : Main@Main
Codec settings/Matri : Custom
[B]PlayTime : 4mn 43s[/B]
Bit rate : 9800 Kbps
Bit rate mode : CBR
Width : 720 pixels
Height : 480 pixels
Aspect ratio : 16/9
Frame rate : 29.970 fps
Standard : Composite
Chroma : 4:2:0
Interlacement : Interlaced
Bits/(Pixel*Frame) : 0.946

I then tried the main movie-all chapters from that same disc and saw the “unsual” PlayTime results:
General #0
Complete name : D:\video7_dvdfabplatinum_vobpassthru.mpg
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 2.76 GiB
[B]PlayTime : 937ms[/B]
Bit rate : 80 Mbps

Video #0
Codec : MPEG-2 Video
Codec profile : Main@Main
Codec settings/Matri : Custom
[B]PlayTime : 1s 251ms[/B]
Bit rate : 9800 Kbps
Bit rate mode : CBR
Width : 720 pixels
Height : 480 pixels
Aspect ratio : 16/9
Frame rate : 29.970 fps
Standard : Composite
Chroma : 4:2:0
Interlacement : Interlaced
Bits/(Pixel*Frame) : 0.946

I then went back to the disc I used in my previous post and did just a single chapter and the results were normal:
General #0
Complete name : D:\video8_dvdfabplatinum_vobpassthru.mpg
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 176 MiB
[B]PlayTime : 4mn 26s[/B]
Bit rate : 5538 Kbps

Video #0
Codec : MPEG-2 Video
Codec profile : Main@Main
Codec settings/Matri : Custom
[B]PlayTime : 4mn 25s[/B]
Bit rate : 9800 Kbps
Bit rate mode : CBR
Width : 720 pixels
Height : 480 pixels
Aspect ratio : 16/9
Frame rate : 29.970 fps
Standard : Composite
Chroma : 4:2:0
Interlacement : Interlaced
Bits/(Pixel*Frame) : 0.946

For reference, here is the main movie-all chapters info for that disc (with incorrect PlayTime values):
General #0
Complete name : D:\video_dvdfabplatinum_vobpassthru.mpg
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 4.02 GiB
[B]PlayTime : 8ms[/B]
Bit rate : 30 Mbps

Video #0
Codec : MPEG-2 Video
Codec profile : Main@Main
Codec settings/Matri : Custom
[B]PlayTime : 284ms[/B]
Bit rate : 9800 Kbps
Bit rate mode : CBR
Width : 720 pixels
Height : 480 pixels
Aspect ratio : 16/9
Frame rate : 29.970 fps
Standard : Composite
Chroma : 4:2:0
Interlacement : Interlaced
Bits/(Pixel*Frame) : 0.946

So, for these two examples, a single chapter produces expected results where the entire main movie does not.

Have you tried all chapters from the disc you used?

Thanks for working through this with me… I’d like to understand if there is something that I’m doing incorrectly and get this to work (hopefully, before my trial of DVDFab is up).

As Dale mentioned in his post… when this does work, the results are fast and of excellent quality.

I don’t think it is anything you are doing wrong, but I’m not sure what the problem is. I will try a full passthrough and let you know how it turn out.

I tried MI:3 full movie, with different results on different players, but the run time reported was incorrect in each case. Playing with WinDVD, the reported run time of 1:01:30 was wrong for the movie, but played out correctly on the player (end credits running at 1:01:00). With VLC Media Player, the time counter reset to 0:00:00 when it crossed the 1:01:30 point. The video bitrate also varied, 4500 kbps in one case, 9800 kbps in another. The movie played perfectly in all players, including my Archos 504. Seems to be the way the players/info software deal with MPEG2. :confused:

Your experiences with WinDVD and VLC are similar to what the TiVo does with these files. It plays fine but, once you cross that incorrect runtime mark things start to get “funky” with the controls.

What did MediaInfo report for the resulting Mpeg file? I’m assuming that PlayTime will be incorrect (I tend to find that the “incorrect” PlayTime - in this case 1:01:30 - will appear in the Audio section).

Any idea how these PlayTime values are inserted into the file and if you have any control over them?

I have a few more tools to look at the file with but no time to do so until Wednesday–just leaving on a business trip and packing only the “stupid” computer.:slight_smile: Maybe someone else can lend a hand until then.

FWIW, I tried the same full movie you and got the exact same results (1h 1mn) when using vob passthru:

General #0
Complete name : D:\video10_dvdfabplatinum_vobpassthru.mpg
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 5.29 GiB
PlayTime : 1h 1mn
Bit rate : 12 Mbps

Video #0
Codec : MPEG-2 Video
Codec profile : Main@Main
Codec settings/Matri : Custom
PlayTime : 1h 1mn
Bit rate : 9800 Kbps
Bit rate mode : CBR
Width : 720 pixels
Height : 480 pixels
Aspect ratio : 16/9
Frame rate : 29.970 fps
Standard : Composite
Chroma : 4:2:0
Interlacement : Interlaced
Bits/(Pixel*Frame) : 0.946

Audio #0
Codec : AC3
PlayTime : 1h 1mn
Bit rate : 448 Kbps
Bit rate mode : CBR
Channel(s) : 6 channels
Channel positions : Front: L C R, Rear: L R, Subwoofer
Sampling rate : 48 KHz

Here is what it should be:

General #0
Complete name : D:\video10_dvdfabhddecrypter_vob2mpg.mpg
Format : MPEG-2 Program
Format/Family : MPEG-2
File size : 5.29 GiB
PlayTime : 2h 5mn
Bit rate : 6038 Kbps

Video #0
Codec : MPEG-2 Video
Codec profile : Main@Main
Codec settings/Matri : Custom
PlayTime : 2h 5mn
Bit rate : 9800 Kbps
Bit rate mode : CBR
Width : 720 pixels
Height : 480 pixels
Aspect ratio : 16/9
Frame rate : 29.970 fps
Standard : Composite
Chroma : 4:2:0
Interlacement : Interlaced
Bits/(Pixel*Frame) : 0.946

Audio #0
Codec : AC3
PlayTime : 2h 5mn
Bit rate : 448 Kbps
Bit rate mode : CBR
Channel(s) : 6 channels
Channel positions : Front: L C R, Rear: L R, Subwoofer
Sampling rate : 48 KHz

If you can figure out what’s happening with the reported PlayTime, I think it would be perfect.

This was high on the list of things I wanted to try with the new version. Will report back.

Just a quick update.

I recently tried with the 4.0.0.0 Beta and got the same results.

P.S. apologies to Dajad for hijacking this thread!

Any updates on this issue?

Hi rjmitche

This is till on my to-do list. Computer problems here have really slowed me down. Sorry. Will keep you posted.