How do you upgrade firmware?

vbimport

#1

i’m totally new to this. how do you upgrade firmware? I went to this page http://www.benq.us/ServiceAndSupport/Drivers/drivers.cfm?product=647 and i want to upgrade my bulk version of benq 1620 to the latest firmware version. I downloaded the zip file for bulk version and upzipped it and clicked the DW.exe and nothing happens… Please help!@!!!


#2

Did you read this:

  1. Firmware Flash User Guide

User Guide for Flashing the Firmware of a BenQ Drive.
Please read carefully before flashing !!

http://www.benq.us/ServiceAndSupport/Drivers/drivercounter.cfm?dpid=647&id=2280&size=416%20KB&type=D&filename=firmware_flash_user_guide.doc&type=D&whereto=ftp://12.145.38.159/dvd-rw/firmware/firmware_flash_user_guide.doc


#3

yeah i read that and tried to find where flash tool is :(. Where can u find that?


#4

The flash tool is in the zip file
Name: G7V9.EXE


#5

whenever i click that i see some notice message and it just disappears


#6

Hi :slight_smile:
Welcome to the forum kp4life. :smiley:
Firstly the official f/w is pretty much click & go. If you’ve downloaded bulk f/w (G7K9)perhaps you need retail (B7K9)[note these are examples & not the latest f/w]. You might want to take a look here.


#7

whenever i click g7v9.exe after unzipping it…
it says …
notice message pops up…

1.Please DO NOT turn power while upgrading.
2.Please ensure that the device is properly installed and DO NOT remove device while upgrading.
3.Please ensure all current applications are terminated before proceed upgrading.

       and if i click ok 
         nothing happens

#8

Is your drive connected internally to IDE or to USB with an external box?


#9

internally to IDE


#10

Hi :slight_smile:
Have you read my earlier post. Is the f/w correct, do you what your current f/w is?


#11

Hi,

did you unzip the archive to an own directory on your HDD or did you just open the zip using your packer software?

Michael


#12

my current f/w is b7t9… I tried b7w9 but the same thing happens… notice message pops up then when i click ok nothing happens …i unzipped to my own directory on my hardrive


#13

Hi :slight_smile:
Thanks for info. Try downloading again just in case that’s the problem. For alternative try here.


#14

I’m not sure that can be related with your problem, but what IDE drivers do you have?

And do you have DMA enabled? Try to follow [B]zebadee[/B]'s method: start windows in safe mode and try to flash your drive in safe mode.


#15

:iagree:

I always flash my drives in Safe Mode…if only to be sure that lots of stuff isn’t running. :slight_smile:


#16

I had the same problem just the other night trying to flash my lite-on drive. The flash file had no instructions at all and when I double-clicked the .exe I got the same instructions and the same results (nothing happened). I then read if you have more than one drive on the same IDE to remove them all but the drive being flashed and flash. I tried this and lo and behiold it worked.