How do u enable digital CD playback?

Hi, my sound isn’t coming out as it used to. I checked my settings & somehow the box where it says “Enable Digital CD Playback” is disabled, but I can’t re-enable by clicking on the box. Anyone got a solution?

Could this be connected with the Popup’s I can’t get rid of? I keep getting Popup’s for Winfixer 2005 & have run Ad-aware, Spybot. I also use Avast, but nothing stops them.

Thanks, Ed.

Doubt it recheck your sound card settings. Also are you using your dig output and input plugs. Try a ac3 spdif cord