How do I update Bios on Dell 1545 with less than 10% battery?

vbimport

#1

Hello everybody

Another Dell 1545 with battery problems here to add to the collection.
I recently purchased the laptop from Ebay and have had to download drivers etc to get it working.
I purchased a new battery too which worked for a month but has suddenly stopped charging and now says "(plugged in, not charging)
Like everybody on here, I have no battery so therefore cannot download the “Bios” upgrade on the Dell website. ( I need 10%)

Iv read through all the other comments and advice and initially it all seemed too complicated to download the Bios -I seriously dont have a clue about computers.
Then I saw some advice…

[I]Man you guys really know how to make something harder than it needs to be. There’s a simple two-step solution that doesn’t require command prompt:
#1. Create a shortcut to the BIOS update executable.
#2: Right-click shortcut, go to Properties and simply add " /forceit" (without quotations of course) at the end. Make sure you put a space between the file path’s end quotation and the /forceit command. Hit OK then just double-click the magical shortcut.

For example:
“C:\Documents and Settings\User1\My Documents\FlashBIOS.exe” /forceit
[/I]
I had a mess around but no joy -where am I going wrong?

This is what im doing…

I go on the Dell website, add my tag number and get given the appropriate BIOS download.
I click on the download then open and it says error.
I go to my Downloads on my computer, its there -(1545_A14). I right click on “create a shortcut”.
I then right click on (1545_A14 - Shortcut)
I click on properties and a box comes up with the target saying "C:\Users\Dell|Downloads\1545_A14.EXE
I then click on this title and at the end, I leave a space and put /forceit (iv also tried \forceit
I click Ok, (Iv also tried Apply too)
I then double click on the “Magic” shortcut and a box opens stating “an unexpected error occured whilst running the Flash application. Please reboot and try again”

I know its all basic lingo but I honestly havent got a clue with computers.

Can somebody offer me some advice as to where i am going wrong or point in the right direction???

Cheers for listening/reading.

Kieran

Im running Vista btw.


#2

Do you not have a power cord supply that came with the laptop? That should suffice to keep power running to your laptop when you update the bios. And if I recall right the bios update is a .exe program and how you have to make a short cut to it sounds odds why you have to do that. I update dell with a battery that was old and not keeping charge as long as you have it plugged in and powered. Also make sure you type the correct service tag number to get to the right laptop page to get the right bios if you don’t do that and mess up then your left with going to a repair shop and paying them to fix the messed up bios. So unless you didn’t use the correct dell service tag to get the right info for your laptop and without that you will not get to the right page to get the right updates or bios or drivers for your laptop. And if you don’t know where to go just call up dell customer service or contact them online. And without knowing what your service tag is for your dell telling you something for dell 1545 will not be helpful since there is no service tag to help identify the hardware inside the dell 1545 and also it won’t give us where to look to help you update your bios.


#3

Hello coolcolors.

I put my Service Tag in the Dell website and it recommended the correct Bios to download (i think it was 14) but it wont let me download it off their website without at 10% of juice left in my battery.
Im guessing its because if I get a power cut then iv got no back up power and my laptop will be killed.
To make a shortcut for the Bios update was to try and install the Bios with no battery power by forcing it -/forceit.
Theres a few other links on here where people have had similar problems but im not “techy” enough to follow their instructions… I needed a copy of updating Bios for dummies I guess!!!
Thanks anyway Mr.


#4

Have a look at this thread.

There are a few solutions in there that might work for you.

[B]Wombler[/B]


#5

Why not get another battery for it before updating to the F14 Bios?

I’ve had excellent luck with the unbranded made in China batteries
(the originals are MiC anyway) sold on ebay for $35

get yourself a chinese GP952 (nine cell high capacity) equivelent
and everything will be in tune with the universe

AD