How do I flash my DVR? is it worth it?

vbimport

#1

Hi all :cool:

i have the pioneer DVR 107D. i’ve had it for quite a while now. i bought it seperate when building a pc about 2 years ago.

i was on the pioneer website and noticed new firmware available.

how do i install this to the drive? and is it worth it?

many thanks :smiley:


#2

Welcome to CD Freaks.

Yes it’s probably worth it & it’s a very simple process. Just don’t have anything else running, no disk in the drive & then run the .exe file that you download.


#3

run it within windows? or from dos?


#4

Almost all firmware flashers from the Pioneer and others are now designed to be run in windows. Make sure you do not shut your system off and make sure you have no discs in the drive. As I recall, Pioneer ejects the drawer on occasion so don’t panic.

For your info, the Pioneer 107 is fairly well past its prime and you might want to add a Pioneer 111, the best Pioneer drive I have seen and as good as anything made today. At $30 it is a steal.

Here is a good source for your firmware:

http://www.pioneer.com.au/products/computer_peripherals/index.html


#5

thanks

i unzipped the file and ran it. now i can’t delete it? it keeps telling me another program is using the file
what program,


#6

Have you rebooted?


#7

i did.


#8

There’s a small app that might help. It’s called Unlocker and found here .

Not used it myself but found out about here recently.


#9

excellent program, thanks :clap: :bow:


#10

btw i still havent been able to flash my drive

i have the file unzipped, R7100107.122 and the UPGR107.exe file

i put these on a floppy but the UPGR107 file said device not found when i ran it in dos


#11

i get this clicking the upgr107.exe file within windows

is this a problem?


#12

Pioneer Firmware will not flash backwards. What is your current firmware?

You can also try here: http://www.dvd-recordable.org/wwwimgs/media/flash/html/Firmware/index.php?path=PIONEER%2FDVR-107D/


#13

I just run the exe from Windows Explorer, don’t worry about putting it on a floppy & booting in DOS.


#14

my version is 1.10
i’m trying to upgrade to the 1.22 which i downloaded from the pioneer site

i tried running it in windows but get the msg i last posted. can’t understand why it doesn’t recognise the drive.


#15

got it sorted, thanks guys :smiley:


#16

HOW??? please post your solution. THX


#17

At what stage did you have problems…?