How can I get this piece of crap (I/O Magic IVDV16DD) to work in Windows XP?

vbimport

#1

My name is Tony, I’m new here and having problems with my burner.
I have an I/O Magic IDVD16DD, which I understand, is just a rebadge of one of several different manufacurers. First off, how do I determine whose burner this actually is.

I’ve always had the absolute worst luck with burners since the begining of time. I think god has something against my ability to burn my own movies and software. I’ve updated the firmware according to I/O Magic’s instructions by going to www.drvupdate.com and running the auto-install utility. After I updated the firmware and restart so I can run the firmware again to make sure that the firm worked and that I don’t need to install another one, I get a message saying that the burner that I have is not compatible with that software even though I just used it like, 5 secs ago. :a

I’ve updated ASPI on adaptecs site, amde sure I’m running the newest legit version of Nero, and nothing. BUT; when I switch my computer over to Windows 2003 (I have like, 10 OS’s on this thing) burner works fine. I’d use W2k3 primarily if I didn’t have to explain the motives for going to certain websites or telling it why I have to restart when I install some type of software that needs me to.

Bottom line, how can I get this piece of crap to work in Windows XP? And how do I identify who the manufacturer of my burner is so I can download the firmware update directly from them? Thanks ahead of time!
–Ippey


#2

LOL, I don’t think He has something against you…

Well, anyway… I’m a n00b here too, but I’ll try. Have you tried Everest Home Edition yet? Don’t worry, you won’t be needing to climb some mountain or something. :iagree:

That might help you figure out whose burner it is…


#3

its a rebadged benq see this thread


#4

OK, I went and I downloaded the BenQ flasher B7M9, but when I select my DVD burner, it says Drive Not Supported. Here’s something else I should tell you too, that may help:
Before I flashed it with drvupdate, when I tried to burn in Nero, it would get all the way to the end, then fail at like 80 or 90%. After the drv flash, it stays on 1% for like, 2 minutes, then recorder state fails and it continues up to 100%, where it just sits there burning…forever…until i restart. Dunno what that means.

How can I get this burner to work again!?
–Ippey


#5

Hello and welcome,

which firmware version is currently installed on your drive?

cu


#6

If it truly is a BanQ 1620 drive it may also be using the OEM G firmware so you might want to try a G version and see if it works. After that you can convert to B if it does. There are threads here on how to convert to retail B firmware.