How can i back flash my 1633s?

vbimport

#1

Hey everyone.

A couple of days ago I flashed my 1633s lite-on drive from the BSOC firmware to the 1633S.BS41 firmware. Now I notice that when I put certain brands of blank dvds in the writer I get an “illegal disc” error when I try burning onto them using Nero. I wanted to reinstall the BSOC firmware. I still have the original BSOC file that I got from the Lite-on page when it came out, but when I run the exe file through Winxp I get the following screen (see the attached pic). Anyone know how I can reflash my drive with the BSOC?


#2

Either use flashfix on the Liteon firmware or use the stock BS0C on our site in this file.


#3

Hello.

Last night after asking for help I downloaded the 1633S.BS0R.stock.rar file from the codeguys website. I tried flashing this to my liteon and it worked. Those older blank dvds seem to work now. My question though is how come this file from codeguys worked, but the BS0R firmware from the liteon page didn’t work? What’s different between them?

Thanks a lot


#4

The original LiteOn flashers only allow upgrades from known firmwares which follow the same naming schema. The step from BS41 to BS0x whould be a downgrade, so it is forbidden. This upgrade check was removed from the other flasher.


#5

Thanks so much for mentioning how to fix such a problem. I did the very thing and I didn’t do a test burn afterwards, I found out a couple days ago that I couldn’t burn any images. I thought it might be just the image but then another image did the same thing.

Various different programs refused to burn, so after going back to an older firmware, it is now burning fine. :slight_smile: