HITACHI GSA-4163B (bitsetting problem ?)

vbimport

#1

i bought HITACHI GSA-4163B ( export japan batch )

but i can’t set the bitsetting why ??
use NERO 6.6.0.6

i saw cdfreaks review this drive can set bitsetting…


#2

I have the same problem. Don’t know why too. But I’m using stock A101 firm. I thought that was the problem with my burner, but now I know it isn’t…


#3

hitachi and lg different ??

how do mod Hitachi to LG identity ?


#4

Tried with Nero CD-Speed as well?


#5

Hi Guys,

I’m about to buy a GSA-4163B from England and import it into South Africa, but I don’t want to do it unless it can support bitsetting. I already returned a GSA-4160B because it can’t support the bitsetting feature.

Have you any ideas why this is so before I buy?


#6

try before dvdinforpro and cd-dvd speed … cannot set !!:sad:


#7

Hi all!

Please note you will need a little bit Fuzzy Logic because my Nero is in German and I translated the Menu/Button names - you are intelligent beings, aren´t you? :wink:

If you want to use bitsetting (which BTW does not work for DVD+RW, I retried several times :a I really [b]hope LG fixes this and makes Booktype settable for DVD+RW too!!!) with Nero 6.6.x.y, go to the “Recorder” Menu in the menubar, select “Choose Recorder” and click the “Options” button at the botton. There you can choose the Book Type bitsetting. I use “Current Recorder setting” anyway and set the bitsetting with alexnoe´s bitset tool on the command line.

You can get it from http://www-user.tu-chemnitz.de/~noe/Bitsetting/.

In Windows, just make a link to it, name it “DVD-ROM DVD-ROM”
(for example) and then change the “Target” line of the link to
DRIVELETTER:\WHERE\IT\IS\bitset.exe dvd-rom dvd-rom debug
i.e. this means just append “dvd-rom dvd-rom debug”
“debug” makes the program show the command sequences and of course you can omit it.

If you want to, make more links like “DVD+R DVD-ROM” where you would append “DVD+R DVD-ROM” and so on. See alex noe´s readme.txt for that http://www-user.tu-chemnitz.de/~noe/Bitsetting/readme.txt

The 1st “dvd-rom” is book type for DVD+R and the 2nd for DVD+R DL

You can also move that command line into your “Autostart” folder. I am not sure whether you will need Administrator privileges to do this, though. Sorry.

This way Booktype bitsetting should work with any writing program you start afterwards. I chose this tool because it is also easily portable to Linux which is my OS :cool:

Hope it works for you!

And big thanks and hugs to alex noe for this!!! :X

Greetz, oman

PS: Once again, though often said: DO NOT SEARCH for Booktype setting with DVD-R/RW/-R DL (are they out btw?) All DVD- (minus) media has a pre"programmed" book type which cannot be changed. Also, don´t wonder when the Booktype might appear to still be DVD+<sth> after burning. DVD+ essentially has two book types, one you cannot change and the one which is used by most players. If you search the forum here, you will find many many post discussing this. Look and learn mates

PPS: IMPORTANT, I just noticed this: Change the setting when the tray is open or anything BUT A DVD-R/RW/RDL is in the drive! Otherwise that setting will disappear. Maybe that is your problem…


#8

Yes you are right - the 4160B DOES DEFINITELY NOT support bitsetting, at least with the standard firmware. So does the Samsung TS-H552B. I am not sure but it looked like bitsetting even damaged the Samsungs firmware (what a crap device - but I love Samsungs HDDs).

The LG GSA-4163B (B is what I have and i can only speek for that one) DOES SUPPORT bitsetting for DVD+R media (I tried), for DVD+R DL media (supposed, didn´t try, I think the media is WAY too expensive atm), but NO SUPPORT for Booktype setting with DVD+RW media :a (w00t)

Always remember: No Booktype bitsetting is possible for DVD-minus-R/RW/… media

Hope it helps.


#9

need time to test out . can work in win xp?

THANK YOU :bow:

===============
who can do the GUI version , so that easy set :smiley:

C:\bitset_commandline>bitset normal normal

Looking for drives…
Broken result received by GetASPI32SupportInfo()

i try on my benq 1620… show this message


#10

[ol]
[li]Yes, my posts above refer to Win XP (SP2)
[/li][li]After setting up the links you need, isnt it as good as GUI? (Even better I think because you can copy one of them into your Autostart folder!)
[/li][li]Maybe you should go to http://www.ahead.de/en/ASPI_Driver.html and download the wnaspi32.dll you can find there. Quote: " the WNASPI may only be copied in the applications folder, but not in the system folder " so basically copy it to the folder the bitset commandline utility is in … and retry then
[/li][/ol]

BTW, the BenQ can do bitsetting with own tools I think? There is also a DVD bitsetter prog with GUI at http://www.dvdplusrw.org/resources/bitsettings.html, so have a look at that one, too

I prefer the commandline tool, anyway. I am not such a fan of GUIs - even less of Win :wink: But it is good as a start if testing new hardware before one tries to use it in Linux/BSD.

Hope this helps!
oman


#11

Bitsetting is working perfectly on my Nero Express 6.6.0.6.


#12

It seems the Hitachi version has bitsetting disabled. The firmware might be different. Are you running LG GSA-4163 A102 firmware on the Hitachi GSA-4163? Hm… Alexnoe’s tool might reveal what’s wrong.


#13

Me, worked both on Nero CD-DVD Speed and Nero Burning Rom. I tested GSA-4163B A100, GSA-5163D A101, GSA-4163B A102, and GSA-5163D A102. Though the firmware itself is the same on GSA-4163B and GSA-5163D.


#14

yap … i flash LG GSA-4163 A102 , A101 , TDB 101,102Auto/RPC …also don’t have bitsetting fuction.

who can modify the serial num ? Hitachi with M alphabet ,LG is K


#15

Maybe it’s disabled in the EEPROM like GSA-4160B.


#16

Bitsetting disabled? Well I just think this absolutely sucks. :Z
Setting fire to the balls of the engineer who had that idea sounds quite reasonable to me fg

Really sorry for that :frowning:

Wouldnt a thread with a list of LG writers / OEM versions and their supported Booktype bitsettings a good idea? Best if it were sticky - or maybe inside an LG FAQ. There seems to be much confusion about that…

Greetz.

Back to Linux for some serious work …


#17

Pioneer, Hitachi, and Toshiba = DVD-R and DVD-RAM groups. :wink:


#18

Me too!



#19

hope that "Dangerous Brothers " can modify firmware , eeprom ?? :smiley:


#20

I guess not … otherwise I think the LG GSA-4163B would already have DVD+RW Booktype bitsetting with a patched firmware. I guess if its disabled in a harder way than just having cleared out the program code, no chance - or at least really hard …