Hex and Bin conversion and Memorex AK

I found out my memorex32maxx AK model is manufactored by BTC. I found some firwares on their download page. The only problem is i can get a hex file when i run their flash program. Clicking “source” option gives access to the hex file, however the resulting hex file is bigger than 512KB from all three firwares on their site. Also i’m assuming they use mediatek chipsets since their dvd drives seem to but mtkflash gives an error “incorrect file format” when i try to to flash with the hex file. Whether it is named .bin or .hex.

If anybody has any firmware for the btc 40x, 48x or 52x burners or can tell me how to convert my hex files from the btc .exe to a bin it would be of great help.

By the way if it helps anyone the first four lines of the hex file from the 40x look like this:

:1008EF0090DB0E012890EAA5012890A5920188902F
:1008FF00C7B0014090D40C014090EE23012890EA3C
:10090F00D90128907B3C012890E8FB012890EB0C43
:10091F00012890E43E012890A614018890CA410155

and so on. A hex file obviously.

Don’t you use /h instead of /b with mtkflash to flash a hex file? Did you try that?

Links to the files you’re talking about would be nice.

I tried using both /h and /b plus both versions of mtkflash 1.48 and 1.55. It gave a message “Err: opening file” something of that nature (the file was there, I checked the disk before each run) and used the hex files for the 40x and 48x burners, the link for the files is:

http://www.btcusa.com/cdrw.html

When i clicked on the exe files it said wrong drive version but clicking on the source got me the hex files which i renamed to be under 8 letters.

You know, I have seen this firmware type before; This drive is the same type as the Sony CRX185E3 which is a 32x burner. I have version L08F for the CRX185E3 that I can send to you, but I’ll be gone this weekend. I’ll send now

It loaded the flashed to the firware but caused an error during burning i’m gonna try some more sony just too see and maybe one or two other firware. Any body have any ideas about the hex file problems?

Nero said:

9:06:13 Burn process started at 32x
9:07:55 Power Calibration error
9:07:55 Invalid write state

So far no luck with any sony firware on this page

http://www.firmware-flash.com/~dhc014/

If it helps at all the 32maxx ak firmware supports mt rainer and smart burn which can’t be disabled.

Searching through the threads I found more information on people who seem to have the same problem as me in not being able to recognize newer media at anything higher than 16x. I’m am now convinced my drive is a BTC BCE3212IM and so far i’ve found firmware for the 48x drive but that seems to flash incorrectly. I would like to try any and all of the btc 40x firmware. So anybody who has it please don’t hold back. I will also let you know if i had any problems with reading cd’s by checking for errors as one person reported after burning at 40x. All this if it works of course.