Help! Won't eject the disc

vbimport

#1

My Philips DVDR 3450H won’t eject the disc! It keeps reading and reading…and then it starts again to read and read…I can’t interrupt it. Tried power off for a couple of minutes. When power on it starts to read and read and read…despite that I’m deperately pressing the eject button. I’ve tried all other buttons as well.

What is this? Shouldn’t the ejectbutton override all activities…and simply eject the disc not matter what?

This really frustrates me. Can anyone help me? Or do I have to go back to the dealer, just because it won’t eject the disc?

Please, help me out of my missery :slight_smile:


#2

I can’t help you on what is causing this , But while the computer is shut down take a paper clip and straighten it out and go in the little hole on the face plate and push in and the burner will open to get disk out. Then try again with a different disk to see if it does it again. If so you may have to R&R it.


#3

Download & install ImgBurn, which is freeware.

http://www.imgburn.com

Go to Tools—> Drive —> Unlock tray

Then Tools —> Drive —> Eject


#4

Edit: I’m pretty sure the 2 above solutions will NOT work since this is a stand-alone device.

I had the exact same problem, came here through Google and thought I’d type a reply with my solution.
I burned a UDF DVD, inserted it into my Philips 3450H, and it kept trying to load it, and load it, and load it. Switching back between TV tuner and DVD mode, making way too much noise, and no matter what I did it would NOT eject the disc. (And I agree that the OPen/Close button SHOULD override everything).

I unplugged (!!) the DVD/HD recorder, unscrewed the lid (you need those star shaped screwdriver bits for this).
Inside you will find a black “DVDROM” device. the part closest to the front of the player had kind of a ‘lid’ with a white circle inside.
Unscrew the small metal strip/plate that holds the lid in place (4 screws), uncsrew the black ‘lid’ part, and you will see your disk.
Remove DVD disk and throw it out. Put everything back together, and in my case the thing is working again.

disclaimer - use above at your own risk


#5

i just had a similar episode with my dvdr 3450h :frowning: the tray is stuck and won’t eject my dvd…
everytime i press the OPEN/CLOSE button the dvd freezes and won’t react nomatter what i do :sad:

is my only option to tear it apart and take out tha dvd like that???


#6

You have a little tiny hole on the front mask of your DVD drive, there you need to put some needle and then press and the drive door will open. :slight_smile:


#7

[QUOTE=ExtremePC;2584348]You have a little tiny hole on the front mask of your DVD drive, there you need to put some needle and then press and the drive door will open. :)[/QUOTE]
A paper clip is perfect for this task.:flower:


#8

Samsung used to provide a tiny tool with their retail drives (usually come with different front plates) for that purpose :slight_smile:

Michael


#9

I’ve had similar problems with a LiteOn CDRW drive failing to open when the open button is pressed. What fixed it for me was to unplug and replug IDE cable and power cable with PC power off and unplugged. This has fixed the problem a couple of times. I’ve no idea of the cause and only know how to fix it when it occurs.