Help with Xbox1 Soft Mod - Mech Installer problems

Hi

This is my first Softmod. I have read loads of stuff online and am stuck.

I used the Mech Installer Game saves - Run Linux, Restore Dashboard and Emergency Linux.

When I run “Run Linux” It tells me it fails and to run the “Dashboard Restore”. When I run “Dashboard Restore” it says it is corrupt (from memory, or something similar). I can run “Emergency Linux” and I have telnetted into it from my PC but I have no idea if this is a good or bad thing as I don’t know what I can do from Telnet. I think my dashboard may be the wrong version but can’t find out the version, I have read many tutorials and can’t see the version number on my machine. I have found a tutorial for changing the dashboard version (downgrade) via telnet but it wants you to upload a file to it (upload fonts-2004-01-15.tar.gz to ftp://192.168.0.3/mnt/E ) but I can’t find where to get a copy of this file. But unless I know the dashboard number or if this is the right thing to do I am stuck.

Can anybody please help me out?

Cheerz
Ray