Help with Sony DW-Q120A

I have a sony DW-Q120A drive and I can’t burn cds or dvds with it, also it can’t read any auto run disks all it can do is read regular data disks. I’ve read a few posts here and learned it’s a liteon drive (don’t completely understand this). I was wondering if anyone could tell me if I can get a new drvier or something to get this drive working. I’ve tried to get the firmware for the liteon equavelant but it didn’twork, is that what I need or what? I’m using xp pro sp2 and i’ve tried using nero to burn. thanks

Hi and welcome!

Stop thinking about crossflashing this drive into a Liteon at that stage.
Either your Windows installation is totally messed up or the drive is defective. Best method to sort that out is trying the drive in another computer.
Also you should use an 80 wired IDE cable to connect the drive.

And another thing: Autorun is bad as this is the infection vector for crap like Sony rootkit or other DRM enforcing “software” rendering your optical drives useless. Being logged on with administrative permissions make things worse :Z

Michael

Couldn’t have said it better, Michael :clap:

Thanks guys. I had been wondering if a reinstall of windows might help. I’ll try what you said and tell ya what happens

Hey guys Reinstalling windows got my drive to work better. I can read any type of disk now. But I cannot burn dvds. I get an error every time I try to burn something. I’ve tried using nero 7 and I got this error about DMA and driver issues and I attached the log it gave me. I’ve also used cdburnerxp pro 3 and got some error message
Does any one know how to solve this problem? It sucks not being able to burn dvds
Thanks

Hi, :slight_smile:

  • Update your firmware to PYS2.
  • Disable Multisession burning in Nero.
  • Disable the IMAPI CD-burning service in Computer Management/Services.
  • Lower burn speed to 12X in Nero.
  • Make sure not to burn data from the hard disk that’s on the same channel as the burner.

Hi,

in addition to Cressida:
You logfile states

DMA-driver error, CRC error
G: SONY DVD RW DW-Q120A
I would suggest to disconnect that Quantum Fireball HDD (Isn’t that one from the museum?) and to check the IDE cable.

Michael