Help with lite-on ltr-48246s that disappeared

Hi. After installing drive it was read by windows as a cd-rom(not a cd rw), but worked well as cd-rom. After searching several places for a way to get windows 98 to read it as a cd-rw; tried installing aspi 4.7. The drive has now completely disappeared and I can not get it back. I have tried removing everything that aspi 4.7 installed(including the dll’s and vxd’s), but nothing has worked. any help would be greatly appriceated as I now have no cd-rom at all. P.S. I do not have an install disk for the drive. The lite-on website says to use the windows default drivers, but I couldn’t find a generic cd-rw driver for win98. That’s why I tried the aspi thing. Thanks in advance.

Probably the best thing to try first is reinstalling ASPI. Not 4.7 though but ForceASPI which contains version 4.6.

It can be found here.

Thanx for the help. After I managed to get rid of all traces of the
4.7 version, I installed the 4.6 and managed to get an updated generic windows driver. Works perfectly now. Thanx again.