Help with DMA/UDMA

vbimport

#1

OK, so heres my problem…my mother and i have identical dell computers (windows xp home)…i run dvd shrink and dvd decrytper frequently…on my machine i can only burn at 1.5x, on hers i can burn at about 9-10x. I have noticed that my machines primary IDE channel is set to DMA if available, but the current mode says PIO. My mother machine is also set to DMA if available and her current mode is Ultra DMA mode 2. Please help me figure out how to get my machine back to dma and faster burning speeds…1.5x is driving me insane! btw the DVD drive is a 16x drive and i have Verbatim 16x, 4.7gb discs…please help! thanks!

-bb4lyfe9


#2

Hi and welcome to the forum :slight_smile:

Sometimes DMA require to be enabled also in BIOS. Check if in your machine is bios-disabled


#3

Try uninstalling the IDE controller your drive is on (through Device Manager - Start > Run > devmgmt.msc) and reboot. Your OS will automatically detect and reinstall the controller. That might help. If it doesn’t work, verify the settings in your BIOS. DMA should be enabled for both the Primary and Secondary Controllers. Best leave it in ‘Auto’. If nothing works, try searching the forums for more solutions. There are lots of threads here that deal with DMA problems.


#4

ok, so i assume you mean to go into the bios by way of restarting and hitting F8?

-matt


#5

ok, i wil try that, thanks sweetleaf and geno888…hopefully one of these will work.

-matt


#6

You’re welcome :slight_smile:

Let us know if you solve the problem


#7

Yeapp. F8, F12, F2, Del… Varies for different types of BIOSes. Usually you will see a pointer printed on the corner of the screen when your machine boots up. If all you see is a splash screen, try hitting the Esc key :smiley:


#8

ok…so i just restarted my machine and went into the BIOS…in the BIOS the only thing i could change or edit in regards to the DVDRW drive was to turn it on or off, there was no mention of DMA, UDAM, PIO etc…so i will try unistalling the drive and see if that works…

-matt


#9

ok, beofer i unistall the drive, i cannot dechipher between the IDE controllers, this may be a tad on the stupid side but how do i determine which one to unistall?

thanks,
-matt


#10

Doesn’t matter, uninstall all of them, THEN restart and check DMA again.


#11

Expand your Primary and Secondary Controllers and find out where your drive is plugged in. Nero InfoTool will also tell you this. Cheers!


#12

alrighty, so i figured out which controller had the DVDRW drive, i unistalled the drive, saw that it no longer exsisted in ‘my computer’, restarted my machine, and went back into the device manager, and in the properties it was set to PIO only mode…so i changed it to DMA if avaiable, but the current mode stayed at PIO…so i dont think uninstalling the drivers worked…any other ideas? why would DMA mode be unavailable? how would i make it avaiable? please and thanks

-matt


#13

Are you sure that there is no reference in BIOS? Can you check again thoroughly?


#14

Yup. The option in the BIOS might be hidden away somewhere. Search each tab thoroughly. And did you restart the machine after you changed the setting to “DMA if available”?


#15

yeah thats what i did, i went through every BIOS option listed from system tools (clock, etc) right down the list to POST which mentioned keyboard errors and such…nothing mentioned DMA…also the first 3 dvds i burned were at a good speed…after that its been 1.5x…i dont know if that helps at all to figure out the problem…oh and no i didnt restart after changing to DMA if available, ill do that…

-matt


#16

Excellent! it worked its now Ultra DMA mode 2…i dont remember all your screenames so ill give a collective thank you to all…really appreciated, and def coming here next time i cant figure something like this out :bow:

-matt


#17

That’s only the first page/subpage of an BIOS setting.

You have to enter another one, containing IDE/DMa info and settings.


#18

You’re welcome :slight_smile:


#19

Glad to be of any help! Oh and welcome to the forum :slight_smile:


#20

well thank you, glad to be here…ive already informed my mother of this forum and the lightning fast responses to problems…i shall return in the future!

-matt