Help with Benq DW1650 drive buffer

vbimport

#1

I’ve currently got two Benq drives. One is a DW 1620 and the other is a DW 1650. The 1620 has been working without a problem, but i recently bought a 1650, and for some reason it won’t burn at the right speed.

I’ve tried it with two different motherboard/cpu set ups and it exhibits the same behaviour. I’m currently running an AMD 3800 Dual Core, ASROCK 939SLI32 with 1 GB of RAM.

WHen i burn a DVD, the drive buffer starts otu at around 90 and constantly drops to about 20-30 every few seconds, then returns to the 90 mark. I’m pretty sure this is the reason the burns are taking a lot longer than they should. An 8x burn takes about 16 mins on average.
I’ve also had the odd coaster every now and then, which i’ve never experienced on the 1620.

I’ve checked the DMA, and its on Ultra DMA 2. The drive is also on the Secondary Master channel. The main hard drive is a 200 GB ATA 100 drive.

If anyone can suggest what might be the problem, it would be appreciated. I’m currently using the latest version of Nero 7 on both machines.


#2

Sounds like WOPC kicking in to me. Mine does the same.

If it was a DMA problem you’d be stuck on 2x burning all the time.


#3

I had the same problem with my 1620. It was caused by a slow hard drive. Not being able to get the data out fast enough. It never happens on my main HD but when i use my old one the buffer keeps dropping and filling back up.

WOPC wouldnt lower the buffer.


#4

You obviously haven’t looked closely enough.

There is a dip in the device buffer level that’s clearly noticeable when burning and in the screenshots fro DVDInfoPro / CDSpeed when they show the device buffer levels from during the burn.

I see it all the time in ImgBurn but I guess it depends on how frequently the burning app checks the current level and updates the GUI.


#5

make sure the burner is not sharing the same IDE cable with your hard drive. Make sure you enable DMA in the cmos. And make sure you load all the drivers for windows including your IDE/SATA drivers. And make sure you install ULI chipset software. Then retest. And since your 1620 works fine, swap the cable/controller that hooked to the 1620 to the 1650 and give it a spin to see if the same problem still occur.

And Welcome to the forum


#6

Benq 1650 is set up as Master on secondary IDE channel.
The Hard Drive is Master on the Primary IDE channel and is fairly modern (Seagate 200GB IDE 8MB buffer).

DMA is definately on, as it displays the Hard Drive is using Ultra-DMA 5 and the DVD burner as Ultra-DMA 2.

I’ve also installed all the Asrock Drivers supplied and i don’t believe there any others. Mainly K8 CPU driver, SATA 2 driver, LAN and Audio drivers. There are no others available from ASROCK.

The 1620 is also on a machine with a different ASROCK (Dual) motherboard, which has an old hard drive 80 GB 2MB Buffer) and it works ok.


#7

I disabled the WOPC and now the buffer doesn’t go up and down like it did.
However, 8x burns are still taking 15 mins.

I’ve tried this with both BCFC and BCHC and it does the same thing.


#8

And what “8X rated” media are you trying to burn? If this media is not supported @8X, it will burn @4X.

As a sidenote, don’t disable WOPC: not a good idea for burning quality, unless you use top-notch flawless pristine media from TY.

Another sidenote: stick with BCFC or BCDC. BCHC has issues.


#9

I decided to get another drive.
Put in a Pioneer 111D and haven’t had a single problem with it. Buffer is fine and burns are great. Installed in the same position the Benq was in. Retried the Benq 1650, and still the same issues.
Guess it must be the drive.


#10

I’m guessing your Asrock is a Nforce4. In which case you probably should get your drivers directly for Nvidia since I suspect AsRock are particularly bad in updating their drivers…

If it’s ULI then get the drivers directly from ULI…


#11

I’m curious. This may be a wrong thread to ask, but the question was raised in this thread. How much does your buffer fluctuate when you burn? On all of my three benq burners (1620/1640/1650) the buffer fluctuated quite a lot, most of the times between 70-90%. At times it would go down to 50%. If I was burning at 12x the average buffer level would be lower than at 8x. I’ve never seen it go empty but I still don’t like it. It’s not hard drive starvation, I have Samsung SP2504C and it should be more than enough to sustain the data transfer. So it is supposed to fluctuate this much?


#12

It doesn’t matter so much what your hard drive is. Nearly all modern HDs should have no problem supplying the data per se. However fragmentation and a shared channel could make problems as well as other demands on HD access.

One way to help diagnose problems would be to use something with an additional memory buffer like ImgBurn (from memory Nero has a memory buffer too). If the memory buffer stays fairly full and your drive buffer goes quite low (e.g. 50%) there could be a problem related to the drive. Make sure the drive channel is not getting excessively used (either give it it’s own channel or put it with another DVD drive which is not in use at the time) and reduce background tasks. Also make sure the drive is at UDMA2. If the memory buffers drops to very low levels there could be a problem on your HD side. Defragment, make sure you end most background tasks etc…


#13

Good advice, but maybe for someone who is new to PC. My ODs are always on a separate channel. Right now my 2504c is connected to onboard sata controller and benq1650 is sharing one IDE channel with Plextor Premium. There are no other devices in the system. Obviously Premium is not used when I burn DVDs. There is no fragmentation either as this is a fairly new install and partition where I keep files to burn is only 50% full. The drive is on UDMA2 and HDD is on UDMA5/6/whatever. There are no heavy background processes, no antiviruses or anything that could affect burning process.

When I burn CDs with premium the buffer level never drops below 95% (of course having an 8MB buffer and lower burning speed helps that), but whenever I would burn DVDs on my Benqs (currently 1650) the buffer level jumps a lot. Nero buffer is always full, not a single drop, but the drive buffer jumps between 70 and 90%. I have always assumed that is how it’s supposed to be, but seeing as this is considered somewhat unusual I wanted to ask.


#14

My 1640 jumps around 85-95% most of the time (it may drop more some times too, I was having problems before so not sure about this. Earlier probs due to imgburn 1.2.0.0 and I’m guessing I was running in to the caching issue so my memory buffer was dropping on occasion).

I believe it may be because of WOPC as lightninguk has suggested. A test write (DVD+R) was possibly a bit more stable IIRC further supporting this idea (I guess WOPC doesn’t really work when your testwriting, if it does, you could always disable it).


#15

The BenQ ones do indeed jump around a lot when compared to other burners. No idea why. I shouldn’t worry about it too much. Some also sit on 100% all the time, others at 90, some at 80 etc. This also changes depending on what you’re burning exactly. DVD+R might be different to -R. DVD might be different to CD. It all depends on how the drive makes use of its cache and is open to interpretation by every drive manufacturer.

The real drop off (when it goes to 0%, 10%, 20%, 30% or whatever) is the WOPC stuff - unless you really are suffering from proper buffer underruns! Buffer drops at regular intervals is (95% of the time?!) WOPC. Irregular intervals is probably bad media (incompatible firmware) or real buffer underruns.


#16

I would only add that in my experience the BenQ’s do
have a varying buffer that seems to be normal, with
the 1650 dropping lower than the 1640.
It’s never been a problem for me and I’ve always
figured it was normal.


#17

In my case, the Benq drops to about 23% with WOPC enabled and doesn’t drop below 89% with it disabled. Yet, the burns still take 15 mins, no matter what discs i use i.e 8x, 16x.


#18

dagoth: It doesn’t matter what discs your using. The question is what speed your burning at… If you always burn at the same speed, the time taken for a full burn will be the same


#19

dagoth_eyre, quite many here have been kind to you explaining that buffer jumps you are talking about again and again are “normal” for benQ’s. Please accept these explanations that comes from some of our most knowledged members and try to look in other directions.

One of the directions might be to test with high quality media from TY, Verbatim, Maxell, aso. Flashing/reflashing firmware, maybe also to earlier firmware, testing with SolidBurn/OverSpeed enabled/disabled, and so on.

Just my $0.02. :slight_smile:


#20

When i said that i’ve used different discs, i actually meant to say that i always burn at the maximum speed, so 8x on an 8x disc and 16x on a 16x disc. I’ve also tried 12x on an 8x disc. Doesn’t eally matter what speed i’m burning at, it always takes the same amount of time.
The buffer isnt as important, although in some cases, a constant reduction in drive buffer every few secods can result in slower burns.

Might have to try flashing back to the earliest firmware, as i’ve used all the options available in QSuite i.e Solidburn, Overspeed etc.