Help! Why my 451s cannot use DVD-r media?

vbimport

#1

Hi all,

I am very new to this and i hope that you will excuse me for some of my stupid questions.

I purchased a new Lite on 451s dvd -/+rw drive and i was able to successfully create 3 backup copies of my own Dvds.
Before i started, i went to Lite On’s web site and i downloaded the latest available firmware upgrade and i successfully upgraded my drive in no time.
All 3 copies that i made on DVD+r disks are excellent and play on my old Pioneer Dvd player. So far so good.

Here is the issue,…i have the drive for a week now and i still have not had the luck to make it work with my Memorex DVD-R disks. I cannot burm movies on them, i cannot burn data on them … the moment i put a DVD-R disk in my drive, the drive “freezes” and doesn’t do anything. I can see on “My computer” that i have a DVD-r disk inside but that’s all. I cannot use the drive at all after this. Nero 6.0 doesn’t see it or is asking for media. And the worst part it is that once the DVD-r disk is inside i CANNOT eject the disk anymore. I have to restart my PC to do it. This is how USELESS my LiteOn has been when it comes to using DVD-r media. I tried 3 different Memorex 4x dvd-r disks - same result. Drive doesn’t “see” them and freezes the eject.

Why is all this happening??? Is Memorex DVD-r media that bad? Is my drive bad? Am i missing something here?? I know that 451s is DVD-r capable. Why i can’t make it work? Any fixes?

Thank you in advance!


#2

put it in another computer
if it does it also put in another computer
if it does it again exchange the drive for another one
if the replaced one does same thing go format and try again


#3

Originally posted by N|KoN
put it in another computer
if it does it also put in another computer
if it does it again exchange the drive for another one
if the replaced one does same thing go format and try again

YES!!! I did install the DVD-r drive on different IDE channel on my PC and now it works. Initially it was connected via Promise Ultra 133 IDE controller card and the DVD-r functionality was missing. Now it is connected directry to the IDE on the motherboard and everything works fine!!!

Thanks for the pointers!