Help? What is needed: Flash, cross flash, none of the above?

My dvd burner is newly purchased CompUsa Norwood Micro Benq 1650. I am trying to back up my a particular dvd of mine but when I pop the disk in it is completely unacknowledged by the drive. I insert the disk, the light flashes for a little bit, and it treats it like either a blank disk or there is no disk whatsoever there. Whenever I look in my computer -> dvd drive, it just opens a blank window so I assume its interpreting it as a blank disk. The dvd works fine on my dvd player.

My question is: Would updating the firmware be a possible solution to this?

Even if its not, Im having issues in successfully doing this. The .exe I get from Benq gives me the message “drive is not allowed to be updated”. Wtf? I understand there is a different way to update with WinDWFlash, but Im under the impression you need .CVT files for this, which I am completely unable to find for benq1650. The benq firmware detector says I currently have GCFC firmware version installed.

Im at wits end, please lemme know what Im doing wrong. :sad: :sad:

Hi, Does your drive work with any other discs? Sounds like it isn’t installed properly. Does it show up in Device Manager? Are you using nVidia drivers? Do you have any virtual drives installed?

Hey thank you for fast reply

  1. Yes this is the first disc it has ever treated like this. Ive put about 60 through it so far and this is the first time.

  2. In device manager it shows up as ATAPI DVD DW 8x16x8x16

  3. Nvidia graphics drivers? I have a geforce mx card, so yes?

  4. I have several virtual drives installed, I will take these down and retry.

OK - NV graphics drivers are no problem, but their mobo chipset drivers can cause some problems. As it’s an OEM drive, the official BenQ firmware may not work with it and you’ll need to use BQFlasher. Search the BenQ forum FAQ on how to perform this “crossflashing”. Not sure whether it will solve your problem with this disc though and it will void the warranty.

Tried removing virtual drives, got same “Not allowed to be upgraded” message.

I tried using the BQFlasher before as well, and I made sure I downloaded the dll into the same directory, but it still gives me the DLL error.

Ok so I successfully flashed with BQFlasher, its kind of idiotic but what the problem was that I downloaded the html page that link to the page that contained the dll file. Im an idiot.

I now have BCDC firmware. The dvd that im trying to copy still is not recognized by the burner. I dont have a different drive to rip it from first, either. Im updating to bchc to see if that will work.

Maybe you should have left it in the BenQ section for the specialists to find it :slight_smile: . Meanwhile you can check here: http://club.cdfreaks.com/showthread.php?t=171380&highlight=flasher (if you think other firmware will help - if it’s just one disc out of 60, I’d say it’s the disc and not the drive that’s the problem).

Yeah thanks for the help Cressida. Im not completely sure its the disk, it runs perfect on the dvd player and my roommates computer runs it, although visually the only thing I see is an initial green screen that fades to blue. If I manage to click the right spot on the menu that I cant see it plays the first episode on the disk and the sound plays just fine. Its weird, this must be some kind of extreme copy protection

Looks like you’ll have to try that disc on another drive/PC, don’t believe firmware can solve it. :slight_smile: Yeah, maybe the copy protection - tried downloading the AnyDVD trial to run in the background?

Yeah I have that already. No software will work since the comp doesnt even recognize that a disk is in the drive

I had a mad dog toshiba dvdrw drive that did this and I wemt to the device manager and uninstalled it rebooted and all went well after that.

you’ll have to crossflash that NORWOOD MICRO rebadged 1650 drive to the official BENQ FIRMWARES. go to the BENQ FORUM and look for either zevia’s or zebadee’s signatures and download the BQFLASHER then you’ll be able to use the official BENQ 1650 firmwares. OEM drives have “G” series firmware which aren’t upgraded often…so it’s best to crossflash your drive to the official BENQ “B” series firmware. But remember that if you crossflash your drive you will VOID THE WARRANTY.

Are you sure you have the drive set up correctly with the jumpers set to master or slave? Check the jumpers on the back of the drive.

Hi :slight_smile:
Welcome to the forum tronman5k. :clap:
Well you’ve managed to crossflash.(A remote possibility flash has taken fully[background pc activity can do this]just reflash the same f/w to elimate this aspect).
As this disc appears to be the only problem. Try slowing the readspeed with something like Nero drive speed.

THIS WORKED! THANK YOU THANK YOU THANK YOU! I slowed it down to 1x and it immediately picked up the disk. thank you thank thank you! I have no idea why it works, but it does. Thanks to everyone who helped :slight_smile:

Apologies for reviving an old thread but I’ve been having a similar problem:

http://club.cdfreaks.com/showthread.php?t=199657

tronman5k, do you think that Nero DriveSpeed could solve my problem?

I’m only asking because I suspect that this could in fact be a general problem with Benq 1650 drives.

I just thought I’d add that I tried using Nero DriveSpeed and it didn’t solve my problem.

It turns out, it was a firmware problem. More details are provided in the thread I linked in my earlier post.