Help: WD Mybook power issue

vbimport

#1

I have the 500GB My Book USB version which was working just fine. The other day I had to discconect it and when I reconnected it I mistakenly used the wrong power supply and well now it won’t power up.

Assuming I fired the enclosure componets, I took it apart and removed the drive itself. I bought a new enclosure, but the drive still won’t power up. I’ve also tried installing it in my pc, still the same power issues.

Any suggestion on how I can get this thing to power back up…

Thanks in advance
Bill


#2

Sounds for me you also damaged your HDD drive when you used the wrong power supply. There is no really easy way to reactivate the drive.

I think the HDD media surface, read / write heads and the mechanical stuff with the positioning mechanism of the heads is still ok.
The only thing that may be work is if you have exactly the same HDD drive you can change the electronic board and recover the data. I read in the newsnet a few times that this worked even with WD drives. The problem is that the electronic board revision must be exact the same, than it could work…

Currentl I guess you lost your data and you can also dump the HDD.


#3

If the Drive is whithin its Warrenty, then phone up the Manufacturer n tell them you pluged it in n it stoped working for no reason…You’ll get a new un.
Do NOT tell them you put wrong power supply on it…