Help w/ Nec 2500a

Ok I just got a Verbatim spindle from amazon and so far i’ve tried burning 4 discs and they all were coasters. Firmware on it b4 was 1.07 and i updated it to 1.09 and still no go. Here is the media code,

Disc Type : [DVD-R]
Manufacturer ID : [MCC 02RG20 ]
Manufacturer Name : [Mitsubishi Chemical Corp.]
Disc Application Code : [Unrestricted Use : Consumer Purpose]
Recording Speeds : [1x , 2x , 4x , 6x , 8x]
Blank Disc Capacity : [2,298,496 Sectors = 4,489.3MB = 4.38GB (4.71GB)]

I’m gonna try 1.91 firmware but im afraid to burn and waste those discs unless i can hear some comments from u guys

I cant find the 1.91 firmware… is it a hacked version?

Yo Snowpeas-

Suggest that you go to Modified Firmware 2.F9-

You can get it here:

http://www.micheldeboer.nl/firmware/25x0.html

Don’t see any 1.91 firmware for the 2500-

Mike

well, my drive is 2500a, when i tried flashing w/ the maddog firmware 2.f9… it says my drive isn’t 2510. Is there a way to turn my 2500a into 2510? and are the hardware basically the same between 2500 and 2510?

Yo Snowpeas-

The latest “Official” firmware is here:

http://support.necsam.com/oem/downloads/flashfirmware/

Think I found the 1.91 firmware here:

http://tdb.rpc1.org/#ND2500A

Mike

Any error message during the burn?

Boot into BIOS and verify that all hard drives and optical drives are seen and set to use AUTO detection. Save and exit. Reboot and go to Device Manager and remove the Primary and Secondary IDE channels. Reboot and verify that devices 0 and 1 in Primary and Secondary IDE channels are set to use DMA mode. Save and Reboot. Verify that all devices connected to Primary and Secondary IDE channels are running in DMA mode. Make sure the jumpers on the hardware are set to Cable Select OR Master/Slave if there are two devices connected to the IDE channel.