HELP: Vista Driver Issue with ND-6650a

vbimport

#1

Hey guys,

I have an Dell Inspiron notebook with a ND-6650a dvd-rw.
So, I have a fresh copy of Vista Business installed, and it initially recognized my burner and everything was fine. I tried burning a data dvd and it said the max burn was 3x, but the max speed on my burner is 8x, so I looked on Dell’s support page, and downloaded the newest firmware upgrade.

All of a sudden, the device manager says that the device isn’t installed properly and windows doesn’t recognize the drive in Explorer. I tried uninstalling it and vista automatically recognized it. Again, it isn’t installed properly… I can’t run the firmware again because it says that the drive isn’t found correctly.

Please someone help me get this working again!


#2

Welcome to the forum. Hard to say what your problem is. I have a Dell as well but I wound up with a 5540 even though my download site says 6650. I hope you didn’t get the wrong firmware. There is additional firmware here but I would only try that as a last resort. Have you checked with Dell? It sounds like a bad flash and they may have some additional input. You might also see if Liggy has any way to force a flash. I know my 4570 was Borked by a flash and there was a trick to get it recognized long enough to re-flash. It had to do with pushing the open button as soon as the drive light showed it had power at a re-boot. Then it was recognized and flashable.


#3

remove the upper/lower filters , could be a longshot , but worth a try
http://support.microsoft.com/kb/314060 (this page applies to xp but as far as i know their in same location on vista so dont worry about it)


#4

Well when i first installed vista, it said it was the 6650a in the device manager, when i went to dells support website, i put in my laptop (inspiron 9300) and it came up with the same burner.

so here is what i did, i went back to the first restore point and it got me a cd rom drive working now… but not the dvd portion. device manager says NEC ND-6550a DVD±RW but when i click on My Computer, it shows up as “CD Drive (D:)”

I am currently running firmware version 103C, Dell’s support website shows me 103D to download for Vista, any ideas if i should do it?


#5

The My Computer info will not tell what kind of drive it is an usually reports a DVD as a CD until a DVD disc is inserted so that is not a problem. If you solved the problem with a restore point, the firmware flash did not cause the problem as it deals with memory on the actual burner, not Windows. It appears that the difference between the two firmwares is very small if any as the 103D made some Dell changes but kept the same strategy number and as you have things working, I would not mess with it.