HELP: Video audio is out of sync on DVD

vbimport

#1

Hi! I have rmvb files on my computer that I’m trying to put on DVDs. So, I have Winavi and Tmpgenc DVD Author. I normally use Winavi to convert my rmvb files to MPEG-1. Then I use Tmpgenc to author and then burn them to DVDs. I just finished a few disc, but the audio sync is off by a few seconds. Am I doing something wrong? I burned them at 8x, shoul I burn it at a slower rate??? Thanks!


#2

You’re converting them to mpeg-1? Mpeg-2 is the standard for DVD video.

Synchronization problems occur during the encoding or transcoding process, so changing your write speed won’t have any affect.


#3

So, I should be encoding them to MPEG2? I read somewhere that said

MPEG 1 = VCD Format
MPEG 2 = DVD Format

That RMVB files are best at MPEG 1

Bitrate 1150-1850 kbits = 4-7 hours per DVD

So, what should I be doing?


#4

The file that you use with Tmpgenc DVD Author should definitely be Mpeg 2, regardless of the format of your source. If your DVD is NTSC (North America), the mpeg 2 file should be 720x480 and 29.97 frames per second.

Play the file on your PC after converting it. If the audio and video is out of synch you’ll know exactly where the problem occured, and the only thing I could suggest is to try a different encoder.

Personally, I use Tmpegenc Plus (http://www.tmpgenc.net/) to convert my files, which seems to work quite well. It has presets to assure your file is DVD compliant. The only thing I adjust is the bitrate, depending on how much video I’m putting on the DVD. I’m not sure if it works with rmvb files though.


#5

Ok, so I should be encoding them to MPEG2.
I only know how to convert with Winavi…I don’t know how to with TMPGenc.

Ok, I’m trying what you have said and when I test it out, I’ll reply.

Thanks Grey for the help!


#6

I’ve never used Winavi, so I’m not sure. But there must be a setting somewhere so you can change the output format.

Another thing I forgot to mention is the GOP setting for your mpeg-2 file. If Winavi will let you change it, you can maximize the quality by eliminating “B” and “P” frames. In other words, set it to use “I” frames only. The only drawback to that method is a larger output file.

On the other hand, allowing P and B frames will result in a smaller file, but you’ll sacrifice the quality. It will also increase the workload of your PC’s processor, as well as your DVD player since the compressed frames take longer to process. If the system becomes overstressed, it could result in the synchronization problems your having.

If you can’t accomplish any of those settings in Winavi, I’d recommend you try Tmpeg’s encoder. It’s pretty simple to use, and they offer a freeware version.


#7

I don’t see anything about P B or I frames in the output area.

There is two options

Fixed output quality
Fixed output size

Default the Fixed output size is clicked.
It says Number of disk 1
Disk capacity which is set at 800 MB


#8

Also, there is a Target scale option

I have it set at auto.

Does it matter???

Should I have to choose either 4:3 or 16:9?


#9

I just took a look at Winavi, and it doesn’t look like it has the ability to alter the GOP. The best you can do with it is to use the “DVD” preset in the drop-down menu (or just click the DVD button on the main interface).

It’s probably best to leave the Target Scale at ‘auto’.


#10

Ok, so when I use Winavi, use DVD option and not the MPEG2 option. I just did it in MPEG2 and the quality of the video doesn’t look too good. It looked alot better with MPEG1.

I’ll try doing it in DVD and see what happens. Also, do I keep setting it to 720x480 and 29.97?

When I was convert to MPEG1 I had my settings at 352x240.


#11

Yes. That’s the NTSC DVD standard.