HELP! Sony DRU 710A @ Lite-On 1633 problem

vbimport

#1

Dear friends, I have some trouble with a Sony drive, which in fact is a Lite-On OEM. The model is DRU 710A. The problem is that it is not recognized anymore by Windows…just as a standard cd-rom. It is even incapable to read anything. I tried to rewrite the f/w using sony or lite-on firmwares. It is seen by those windows flash utilities as : " yyyyyyyyyyyyyy yyy" . No succes in changing the firmware. The program just hangs at 100%, the green led from the drive is on, the tray is unresponsive. After the reset, everithing is “back to normal” : " yyyyyyyyyyy yyy" is the name of the drive and the firmware… :sad: .
I have to mention that in bios it is detected ok, as beeing a sony dru 710 A with byx2 firmware. I also tried to flash it with mtkflash, but still no succes, the drive was not seen by the program. It is installed as primary master, with a lite-on cd-rw as slave.
Plese give me some ideeas for this problem…


#2

remove the drive from device-manager and restart your computer. it should be correctly recognized. if not, try to flash with this firmware: http://codeguys.rpc1.org/firmwares/1633S.BS41.patched-cf.rar


#3

Thanks, but I tried all those… :sad: . Windows, after each and every unistallation of the device from the device manager asks for drivers for it, it doesn’t recognise it as it is…


#4

Try to use mtk169 to flash your firmware in dos. Mtk180,180.1 and 183c don’t support my 1213@1653CS0G. If you fail again, pls post how it fails. By the way, did you try to flash a firmware to your drive and made this happen?


#5

It’s true that I only used Mtk 1.80, 1.81, 1.83c . I will try also with 1.69.

When I tried to flash it with mtk 1.80 @ cs0g it just hanged at 00%…

Ies, it was totaled by a failed flash procedure made by a friend of mine. :frowning:


#6

I just finished trying with version 1.69 of mtkflash…useless. The program hangs up just before beggining of the flash process:

after the command :

mtkflash 4 w /b /m by01.bin , it is displayed the following line:

mtkflash by joseph lin mtk, 1998, ver 1.69

Here the computer hangs up, it becomes unresponsive.

:a :a :a :a

Any other ideea will be apreciated.


#7

Time to read the mtkflash instructions. ‘4’ were secondary slave.


#8

Well, I didn’t made any mistake here, because it’s place in the system was taken by other drive, so the only free location was the secondary slave, “4” for MTKflash. when I tried the flash procedure, I unplugged the power from the other devices.
I am SURE that it was placed well, I even placed it taking in account a MTKflash tutorial which said that it’s preferrable for the drive to be a “secondary slave”…

A new fact about my almost dead drive is that it’s green led keeps on flashing no matter the situation…always bleeping. Is this the END ?


#9

that’s the “dead-drive-blinking”. it appears when you misflash your drive.


#10

Right, but a flashing led means the drive still has a heartbeat. Trying to flash the firmware on a different pc using a different chipset might be a good idea.


#11

Two days ago, I misflashed my drive with sony 720 jy02 fw and made it a total dead one. Only mtk.v1.69 I could use to flash it back. I just misflashed my driver with byx02 to simulate your case. Unfortunately all the mtk.version did not work.
As your window still recognise your drive, you may try ltnflash124 with update and update boot code enable. That is the way I do now. Good Luck


#12

Where I can find “ltnflash124” ? what firmware do you think it’s best to use with this utility?


#13

Well, I did it! I killed it ! :stuck_out_tongue:

I found the “ltnflash124” and I used it with by01. It’s true, that for the first time i’ve seen the red light coming from the led of my drive. It just stayed on…After 10 minutes my computer became unresponsive, i hit restart button and there it was : not even seen by the bios, making the computer unbootable.
Now, when I’m plugging in the device it does not blink , and the eject button isn’t working anymore…

What should I say? Rest in Peace? or there is still a chance?


#14

It is not hopeless yet. A misflashed dead drive is normally not detected by bios and eject button is nonfunction. The only way to flash bach is to do it in dos mod again. Since you have flashed it with by01 for 10 minutes,although not successfully, the firmware should be burned into the eeprom partially and it should be supported by mtkflash 1.83c or 1.69. So try to flash with mtkflash and see what happen.
Good luck.


#15

Thank you for your support, guys, I will go back to MTKflash…I will post as soon as I will make the procedure…I will try with 1.83c this time.


#16

I have stimulate your case again and successfully flash back my dead driver. I used mtkflash 1.8 and put the driver in pri mas and pressed the eject button when the pc is boot up. It works.


#17

Well, I’m starting to think that I’m fighting for a lost cause.

First I succedeed in flashing the drive with mtkflash 1.83c with sony byx3 firmware. I booted the comp with no drive connected, and I connected the dvd-rw just before hitting enter. And it worked. The disapointing fact is that the drive came back to the first stage, the one with the blinking led. The bios recognised it as a sony, the system as “yyyyyy…”. The led blinking…

Back to flash procedure again: This time I turned it into a Lite-on 1633s with BS03 firmware. Same thing: blinking led. windows recognised it as : " I…I ".

Ok, never mind I said. Let’s get back to sony, maybe it is not pleased with the new identity. Mtkflash again… succesfull procedure…WAW…It’s a SONY! I choosed for this time the stock firmware, the original one : BY01. I even restarted with the pressed eject button. Guess what : Blinking led!

Windows sees it again with “yyyyyy…”. I installed it on a IDE RAID, it’s stayng there, with “a blinking eye”. When I insert a cd or a dvd, it just spins it well, the sound of the mechanism is quite obvious, it’s trying to understand something from the inserted media.
The blinking is quite annoing because toghether with the drive’s led also blinks the hdd led. :a

I have second thoughts about this drive, I think that maybe it’s problem isn’t the firmware but the hardware…I don’t know, maybe it’s IDE interface, a chip or smth.
Anyone with this experience?

I keep on fighting because the drive is new, I only burned 20 DVD’s with it and 0 cd’s . I can’t return it to Sony, because the sticker from the side was broken when I first inserted ir in my case… :frowning: .

Any new ideeas?


#18

You have successfully flashed your drive with mtk1.83c. The drive should live. From your previous description of proecdures, it is likely that you have window or other hardware problem. Simply use another pc to flash with mtk again and see whether the window recognise it or not.
Normally after the drive flashed with mtk.successfully, just reboot your system and hot plug your ide channel may be dangerous.
Pressing the eject button is to activate mtkflash works. If your 1.83c works ,just forget about it.
Cdrom or dvdrom may not work in raid channel. Just put it in ide port.
Good lucky.


#19

I only hot plugged the power cord to the drive just before the flash procedure. As reeded in the mtkflash instructions.

I also noticed in the omnipatcher that it can fix the “dead drive blink” … is is true?


#20

yes, omnipatcher can fix it.