Help revert LG WH16NS40 back to FW 1.02 or crossflash

Only you can do it through an unlocked flasher.


Try on the older system

I have just tried your unlocked flasher and that flasher.exe program on Windows 7 and still doesn’t work.

I still get the same message above with your unlocked flasher and flasher.exe doesn’t work at all as it says Win 7 isn’t compatible.

We do not have a factory model to test.
Maybe HLDS blocked something in the fw.1.03 software
I will consult with @ blackened2687 what may be the problem.

I suspect the same indeed.

Try to run unlocked flasher as an administrator (“Run as Administrator”)

I did that and still the same issue.
I even just connected the drive to another PC running Windows 7 that worked with flasher.exe this time but also failed flashing or even extracting the firmware. The Unlocked flasher also didn’t work neither by running it normally or Running as an Administrator and same error message:

It looks like there is a problem with saving the software recorder in ROM.
How can you copy a 1.03 firmware and send it to us.
Maybe there we can find something to explain this situation.

My thoughts exactly.
I will try to exctract FW 1.03 again but I don’t think it will work.

Is there any way for you to check it from LG site?

https://www.lg.com/us/lgecs.downloadFile.ldwf?DOC_ID=20150541945529&what=MANUAL&fromSystem=LG.COM&fileId=PQ3q5aildMcctDRaNYPNmQ&ORIGINAL_NAME_b1_a1=WH16NS40.zip

A copy of firmware 1.03 must be copied directly from the drive WH16NS40 fw.1.03

Exactly as before:

command:
flasher -d [drive id] -l firmware.bin 6 00000000 00200000

where drive id is the drive number.

Doesn’t work for FW 1.03 it seems

It looks like access to the device has changed.
Make a drive ownership screen in OptiDriveControl and DVDInfoPro version with firmware 1.03

I don’t know if these are the right screenshots you need or not but here they are:

Also in the supported features list from the drive with 1.02 FW and from the 1.03 drive. Feature 010dh Supports AACS Active for 1.02 and blank for 1.03

On the LG BH16NS55 updated to 1.03 there is an identical problem with writing software in the drive’s ROM. (Write DRAM NG 05/24/00)

The access parameters to the device were probably changed.

Thank you very much for the explanation.

Is there anyway for you to fix that or is it irreversible?

I’ve moved this thread to our new Ultra HD Blu-ray Forum. The topic was posted in the correct forum, but now we’ve added a special UHD BD Forum, and this drive is UHD BD ‘friendly’, we thought it would get some more attention!

Just thought I’d give a heads up, I ordered a WH16NS40 from Newegg and it arrived manufactured in December with 1.03 FW on it. :frowning: So buyer beware, and I will be watching this thread with extreme interest.

1 Like

I bought another one today from a third party seller on Amazon who I bought my last one from a few weeks back. Crossing my fingers on another 1.02 drive.

Figure I better buy a backup just in case (and while I hopefully still can)

Thanks for letting us know! Did you try to flash back to 1.02 or are you not interested in getting it back to UHD BD friendly? :slight_smile:

@halestorm - Bummer. After LG announced the firmware “upgrades” (and it was confirmed that they should be avoided), I ran out to my local Fry’s and grabbed a couple of friendly drives that I knew would be safe. Seems I wasn’t alone, as both were running low on stock. I was hoping it wouldn’t take quite so long for updated drives to hit the shelves. I guess I was wrong. :confused:

That said, if anybody does live near Fry’s, I highly recommend that they pick up a friendly drive pronto if they want one. Stock was already running low on the two I picked up, and I believe one of them (LG BE16NU50) was out of stock the last time I dropped by. I’m sure Fry’s will restock eventually. I just don’t know what FW will be on the drive, if LG issued a secret recall of some sort (I’m guessing not but who knows), etc. At least the Asus BW-16D1HT appears to be well-stocked. Between that one (there’s also a $25 mail-in rebate if you buy by the 31st) and perhaps a Vantec USB 3.0 enclosure, you should be good to go.

My second WH16NS40 (SVC NS50) showed up from Amazon today and it has 1.02 on it. Guess I got lucky. Going to store it as a backup for now.