Help reinstalling 2nd IDE channel

vbimport

#1

Crossflashed LiteOn 812 to 832 and tried burning at 8X with RitekR03. Burn was very slow, about 1.5 hours with the DVDROM LED flashing red and yellow constantly. Updated to CG5E (was VS0E) and tried burning again with the same results. Searched for answer and a LiteON FAQ here on cdfreaks says that the drive might be on PIO. Sure enough, device manger says PIO for both my LTN163 and 812@832. Switching modes and rebooting several times doesn’t work, so as suggested in FAQ, I uninstall the secondary IDE port that my opticals are on. Reboot and get the following error:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

Device manger shows a ! next to the IDE channel. Google around and find a page that suggests deleting C:\WINDOWS\system32\drivers\atapi.sys. Tried that several times and at each reboot, I get the above error message about driver not intended for this platform. I’ve tried new intel chipset drivers (875P), but that doesn’t work. I think it’s not really a chipset driver issue since this is for the IDE channel which is normally a Microsoft driver (atapi.sys)? I notice that even if I erase atapi.sys, it reappears after reboot

Anybody know WTF is going on?
This is WindowsXP Pro SP1

I saw a thread about the DMA 6 error fallback to PIO bug in Windows, should I apply the hotfix? Should I update to SP2? Don’t really like the thought of reinstalling XP.

Thanks in advance
Ed


#2

Hi Ed,

Before flashing the drive, did it work correctly? The symptoms you describe are typically for a drive in PIO mode, but it shouldn’t conflict like this after the flash (switching back to PIO mode isn’t an uncommon thing, but it should be changeable in Windows).

What chipset is there on your mainboard?
If you have a SiS, ALi, ATi or VIA chipset you really need the chipset driver to get DMA mode working correctly. If you have an Intel or NForce chipset, installing chipset drivers might give problems (not likely here as you were running on MS IDE drivers).

You also might want to check your BIOS to see if DMA is enabled for the IDE channels.
Good luck :slight_smile:


#3

Before flashing my 812, I was at US0G and my first 8x burn was a coaster, so I upgraded to 812@832.

As I noted above, my chipset is an 875P (intel).

My BIOS doesn’t have DMA settings for the IDE channels.

Funny thing is that eventhough my 2nd IDE channel driver isn’t loaded, my optical drives are visible? Do I need an IDE driver to get DMA?

Ed


#4

DMA is donw through windows.

Yuo can try below if you need some guidelines.

http://club.cdfreaks.com/showthread.php?t=101616


#5

Hmmm… My previous post didn’t make it?

Womble, that’s the exact link I used. After a few reboots, I still couldn’t get the optical drives to use DMA, so as suggested, I uninstalled the secondary IDE port, but when I rebooted, I rec’ved that error message in my first post.

I did manage to get it working and I hope this helps someone else. I noticed that the add new hardware icon in the systray was seeing the IDE device, then seeing the optical drives, Then ID’ing that the secondary IDE channel needed to be installed, then I would get the error message about the incompatible driver. I disconnected the IDE cable from the second IDE connector and powered on. This time the driver installed correctly. I think that the optical drives were being recognized before the 2nd IDE channel driver was installed and this caused XP to think that its driver was not compatible, – don’t know why this should happen.

Powered off and reconnected my 2nd IDE cable and booted XP. Checking device manger, both my optical drives are using DMA.

Regards… Ed