Help! Problems with ZS0G - Can't revert to ZS0A

vbimport

#1

Hey Folks,

I tried the ZS0G firmware update on my 40125S with some initial success but have found after a few tests that it leads to C2 errors at the 3/4 mark and up, so I've tried to dowgrade it to ZS0A again, unfortunately to no avail!

I first tried with the MTKFLASH utility with my previously backed up ZS0A.BIN file but the file could not be read by the MTKFLASH version I used to read it with! ([mtkflash 3 w /b rs0a.bin] in pure DOS, win 98SE). To find out why, I then read the ZS0G firmware [mtkflash 3 r /b rs0g.bin] and got a file that's 1/2 the size of the ZS0A firmware I had read previously!

Thinking it might be a problem with the MTKFLASH utility, I then tried to download it and the RS0A BIN file from OC Freak's site but the RAR files show an error message when trying to unpack ('unknown packing method'). I've tried reinstalling WinRAR 2.71 to no avail. I even tried to download the files using ReGet, same result. OC-Freak, I don't understand why I can't unRAR these file, as WinRAR works perfectly otherwise!

I then tried with a patched ZS0A.EXE firmware replacing the first occurence of the string ZS0A in an hex editor with ZS0H to force the windows flasher to flash even though I had the newer ZS0G on but the flashing didn't seem to work correctly, as the drive did not show its green led on while 'flashing'! (upon making a CDSpeed Transfer Rate Test, I get an error right at start, and Nero says the medium is not empty eventhough it is)

I was able to re-force flash in DOS to ZS0G but I'm stuck with the same burn quality problem. I'm at a loss at what to do next, any help is welcome!


#2

Hey 83bj60, great to see ya again :smiley: Looking forward to my next review? it’s near finished now…

1: Make sure that you use mtkflash 1.48
2: My rar files is perfectly fine, but you need winrar 3.0 to unpack them.
3: The correct bin file size should be 512k.

Hope that helps :wink:


#3

Thanks for your very speedy reply, OC-Freak! :slight_smile:

I will download WinRAR 3.00 shortly and let you know how it went.

Thanks again, good buddy! :slight_smile:


#4

Thanks again OC-Freak for your great help!

I susccesfully flashed the 40125S back to ZS0A. Indeed you need WinRAR 3.00 to open those files… :wink:

If I may comment on the new firmware ZS0G: The P-CAV ZS0G is indeed faster than the Z-CLV ZS0A but only by about 10 to 15 seconds or so on a full 80 minute data disk which OTOH gives more reliable results. The P-CAV method, however, gives nicer looking disks.

One weird finding, I could not set the speed correctly in cloneCD with the new firmware.

Tests were done with cheap Princo media certified for 16X to better reveal errors. On Kodak Golds, no errors were found on the few disks I burned even when the speed exceeded the max of 32X reported by CD Speed and Nero.

Conclusion: it’s a mixed bag. ZS0G looks very promising, but I think we will need better media to take advantage of it’s slightly improved performance.