Help! PlexWriter 12/10/32A

vbimport

#1

I need to downgrade my firmware so i can easily burn SafeDiscv2 Discs. Does Anyone Know How?


#2

Yes, we know how, but downgrading your firmware is a waste of time. It will not improve the burning of SafeDisk2. This was never true and is a rumor started with false information. Use the latest and best firmware, v1.09.

Use Beta Blocker or AWS (Amplify Weak Sectors) in CloneCD or S.A.M. in CD Mate. Processing this way will usually result in a successful SD2 copy with your Plextor.


#3

And besides most Plex 1210A writers won’t even allow downgrading before a certain firmware version. You won’t be able to flash to 1.4. Take Inertia’s advice on this one.


#4

thank you guys much! :smiley:


#5

It’s not a rummor, yesterday i’ve made the downgrade to my PlexWriter 12/4/32s and finally i’ve done a successfully clone of MOHAA with CloneCD and BetaBlocker for 2.51


#6

Originally posted by Thantelius
It’s not a rummor, yesterday i’ve made the downgrade to my PlexWriter 12/4/32s and finally i’ve done a successfully clone of MOHAA with CloneCD and BetaBlocker for 2.51
BetaBlocker doesn’t need a downgraded firmware to make a good back-up! Absolute nonsense if you ask me. The firmware 1.4 issue was that when you used this firmware it would be possible to make a good (read: working in all drives) back-up of a normal (non SD2.51) SafeDisc 2 disc without the use of BetaBlocker or AWS (these tools weren’t even available at the time of this rumour).


#7

Ok, say what you want, after burn more than 50 coasters, after downgrade the firmware from 1.07 to 1.04 the backup works.

Magic??, i don’t thik so…


#8

Originally posted by Thantelius
[B]Ok, say what you want, after burn more than 50 coasters, after downgrade the firmware from 1.07 to 1.04 the backup works.

Magic??, i don’t thik so… [/B]
You sure?? Well I still feel that something else must have caused it but hey if you say so. It could very well be… :confused: :confused:


#9

howd you down… oh wait thas the 12/4/32S… i have 12/10/31A


#10

Thantelius

The rumor that was referenced was about the Plextor 12/10/32 only, and not your drive.

Be aware that by downgrading the firmware, you have degraded the general writing capabilities of your drive.


#11

Not entirely true Inertia, the original posts regarded the Plextor 124 SCSI writer:

The marriage of Plextor and SafeDisc 2


#12

G@M3FR3@K

Do you belive me now??

I’m happy because finally i can copy the SD2.51 :smiley:

Now i need to find the way to copy SD2.51 on my LG 8240, Any idea??:confused:


#13

Yes, I was aware of that G@M3FR3@K.:slight_smile:

I was referring to the rumor about the Plextor 12/10/32, which is what got all of the attention. The PX-W124TS was hardly ever mentioned, as there were probably not that many of these drives out there in use by people who were interested in copying SD2.

It may be that this procedure works with the PX-W124TS, but that is beside the point. The story of the firmware downgrade working with the 12/10/32 has been thoroughly disproved by many testers.

The topic of this post is Help! PlexWriter 12/10/32A, not the 12/4/32S model.


#14

Yes, now i’m trying to test the downgrade on a PlexWriter 12/10/32A


#15

Be sure to give us the results, especially if it doesn’t work.:smiley:

Corrected beer-induced spelling error:cool:


#16

Originally posted by Inertia
Be sure to give use the results, especially if it doesn’t work.:smiley:
LOL :smiley:

Now i need to find the way to copy SD2.51 on my LG 8240, Any idea??
Read this thread.


#17

Originally posted by Inertia
[B]Yes, we know how, but downgrading your firmware is a waste of time. It will not improve the burning of SafeDisk2. This was never true and is a rumor started with false information. Use the latest and best firmware, v1.09.

Use Beta Blocker or AWS (Amplify Weak Sectors) in CloneCD or S.A.M. in CD Mate. Processing this way will usually result in a successful SD2 copy with your Plextor. [/B]

MY mate owns this particular PleX drive (IDE model) and can burn SD2 @ x8 and all the backups work perfectly.

Greetz from The Diplomat:D


#18

the latest firmware for the plextor 12/4/32 s ( scsi ) is 1.04 and then Thantelius said he downgraded from 1.07 to 1.04 ?? ,
anyway i leave this thread ,
good luck ,