Help! Plextor 716A burning quality problem

vbimport

#1

Hi, guys, my Plextor 716A seems not pleasant in my computer any more. I do need your kindest help.

It was fine when it was in my Dell 400sc. After I moved it to my new computer with an AMD processor, I have the problems. I can still burn DVD with Nero 6 Ultra (same software and same DVD blank media I used before), but the movies, no mather DVD, AVI or RM just cannot be played smoothly (it was full of mosaic or only sound but no pictures). I tried to burn a few more times, no luck. Then I used a Khypermedia 8X DVD burner in the same computer burned the same files with the same Nero software and DVD media, there was no problems at all. I really feel unhappy with this because the Khypermedia burner I have is free after rebate but I paid a lot more for this Plextor 716A. I also downloaded the newest firmware 1.09. But the burner just couldn’t let me upgrade it. I exchanged to a new IDE cable but still no luck. Is there anything wrong with the Plextor driver? Should I RMA it? It still can read and play DVD through. I don’t know what’s wrong because it was pretty solid before.

Thank you all.


#2

Hi Enzyme: welcome to CD Freaks!

Don’t RMA it yet and let’s try to troubleshoot. First we need more info:

Let us know!


#3

Zevia, thank you so much for your kindest advice! I will check it when I go back home. But I do remember the burner is DMA enabled. But I don’t remember the DMA mode, maybe 4, or 5. Anyway, I will report back later. Thank you again!


#4

Ok, below is my updates.

  1. My PX-716A DMA mode is ultra DMA Mode 4. The burst rate from Nero CD-DVD Speed check is 34MB/s.

  2. I am using Verbatim 8X DVD+R. From Nero Disc Info, it shows Verbatim, MCC003.

  3. I still cannot upgrade the firmware. The Error info is Firmware update is failed. Firmware transfer data error. (Code 04-40-f6)

  4. I did the Self Diagnostic test, the disk ejected automatically after the test. So the DVD burner itself is good?

I tried to burn a rm video file just now. Still the same problem. Any suggestions? Than you!


#5

Well, I found in my hardware device manager, there is a yellow question mark on the SM BUS controller, is it the problem? I will download the motherboard chipset driver and fix the problem. I will let you know after that.


#6

Updated the motherboard chipset driver and resolved the sm bus controller problem. I still cannot update the firmware for the Plextor burner. And the RM files I burned still has the same problem. I really hate the burner now…

Thank you all…


#7

If you put the drive into PIO mode or install the DMA jumper to force MWDMA, does the flash worK? Could be a timing issue if it does. What is the AMD chipset you have? I seem to remember some time back that Plextor was rumored to have a fix for an AMD timing issue.


#8

No, I haven’t tried PIO mode yet. All the posts tell the goodness of DMA so my brain just thinks about DMA is good, blah, blah, blah…

My AMD CPU is Athlon X2 3800+. I also installed AMD CPU driver.

Thank you so much for your reply!


#9

WOW!!! Bob11879, you are the MAN!!!

After I changed the drive into PIO mode, I got PERFECT movies!!! Also, it allowed me to upgrade the firmware!!! What the hell is going on with my AMD chip? Damn!!! I really spent too too much time on that. Thank you all so much!!!

BTW, does this mean I have to use PIO mode for this driver forever? What the advantages of DMA? Much faster? Anyhow, for successful burning, I have to stick with PIO mode for now.

Is this a bug of Plextor driver with AMD CPU? Why cannot they fix that???


#10

Check with Tech support for an updated firmware, if they have one. At a minimum the configuration will be reported to them. Your mobo mfr is like a lot of vendors that make vast quantities of products. Not one size always fits all. Some peripherals may have a problem. Not a bug with either, just a compatibility issue. The mobo vendor is like the 800 pound gorilla…it’s usually the peripheral vendor that finds it easiest to fix the problem…


#11

Set the transfer mode to PIO and then flash it. It will flash properly. You can later set the mode back to DMA.


#12

[B]jclimaye[/B], I believe the original poster lost interest in this topic as the last post is more than a year old. :wink:


#13

I guess so, but I have been absent here for two years. And I thought it would be useful for anyone who faces this problem