HELP please! Lite-On 1633s or now 1653sCSOT

Ok, I was having issues with my lite on burner which was installed new in my HP Pavilion. Wouldn’t burn using the windows folder, didn’t think much of it. Was able to use AnyDVD and DVD clone, the uninstalled them and went to back up some files witha dvd and the thing won’t burn just ruins new dvd’s. I thouhg it was the media. So I went and bouth verbaitum lightscribe dvds which I had been wanting to try. And still the same thing. I found a firmware upgrade to 1653s csot and ran it. Still nothing did I mess up somewhere or is this thing honestly fried? How can I go back to 1633s B… ? I also installed diagnostic software from lightscribe and is says everything is fine. when I go to use their lightscribe labeling software it says no lightscribe burner is found?

Please help.
Thank
Kris

Also I get constant blinking green light

Welcome @CDFReaks, [B]Racer23[/B] :slight_smile:

  1. “Burn using the windows folder” only works with CD, not DVD. You need to try with a dedicated burning app like Nero.

  2. LightScribe labeling only works with LightScribe capable drives, which your Lite-On model isn’t.

I used nero and it doesn’t even recognize the DVD’s haven’t tried cd’s yet.

Now I feel stupid about the lightscribe thing. :Z

Any way I can restore this thing back to 1633s? Codeguys site is down?

Kris

Codeguys site works here, but this is not likely a firmware problem. Could be your drive is dying - easiest way to tell is to try it in another PC. First see if it still boots from a bootable DVD (like Vista or Linux).

Codeguys site is up again, visit it and try to find that B… firmware.